Bad Vantec SATA to USB adapter?

Discussion in 'Mac Accessories' started by ma5ter5, Aug 8, 2013.

  1. ma5ter5 macrumors member

    ma5ter5

    Joined:
    May 17, 2010
    Location:
    Outside
    #1
    Hi,

    I recently purchased a Samsung 840 series 250GB hard drive for my 2010 13" MBP. Previously I had a 750GB WD Black HDD that I was using in the computer. When I connected the 750GB drive to my computer via a Vantec SATA/IDE to USB cable, I received an error message that the drive could not be read. I thought at first maybe my drive was bad, so I got a new one from WD. I attempted several times to install via the cable 10.6 that came with my computer, upgrading to 10.8, but always received error messages when the installer for 10.8 ran.

    I eventually installed the WD drive in the computer and was able to successfully install 10.6 and upgrade to 10.8 and recover my files from my time capsule. I then took the drive out and reinstalled the SSD and again attempted to transfer files via the Vantec cable. Again I got the same error message.

    I'm assuming at this point that the Vantec cable is bad? I've never had previous problems with the adapter, but I think I've isolated the problem to it. I did use the cable to successfully get 10.8 installed on the 250GB SSD without issue via CarbonCopy from my 80GB backup drive. Would the problem be isolated to using on the larger drive?

    Thanks,

    Steve
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    "I'm assuming at this point that the Vantec cable is bad?"

    You've tried to use the Vantec dongle several times -- and it has repeatedly given you problems.
    I would assume that something isn't quite right with that adapter.

    What I suggest you do is get something better. I'd recommend a USB3/SATA "docking station". Many are available, to see what's out there, go to amazon.com and enter "usb3 sata dock" in the search box.

    One product I have used personally is this one:
    http://plugable.com/products/USB3-SATA-U3
    (no financial interest, just a satisfied paying customer)

    You also might be interested in these (they are for 2.5" drives only):
    http://plugable.com/products/pss-dd1
    (has dual 2.5" docks)

    http://plugable.com/products/pss-sdh1
    (has integral USB3 hub)
     

Share This Page