Bad Wireless Connection: Airport Extreme with D-Link DI-624 Router

Discussion in 'MacBook Pro' started by Feldie, Jan 16, 2009.

  1. Feldie macrumors newbie

    Joined:
    Jan 16, 2009
    #1
    Hello:

    We have two Macs. PowerBook G4 and MacBook. Both I think are 2005 models. Both have Airport Extreme wireless cards (though slightly different models).

    We have a D-Link DI-624 AirPlus Xtreme G wireless router. The two mac notebooks get dropped from the networks for extended periods. My PC laptops do not have this issue.

    Overall the macs seem to have a slower connection.

    Does anyone have any suggestions?

    Thank you.
     
  2. mac-raster macrumors newbie

    Joined:
    Mar 30, 2009
    #2
    D-Link DI-624 Router & MacBooks

    Hello,

    I have a similar wireless problem with 2 generations of MacBooks. Windows machines connect fine in wireless, MacBook connects fine with Ethernet cable.

    Did you ever find a solution to this?

    Thanks.
     
  3. capriseyhaze macrumors regular

    capriseyhaze

    Joined:
    Mar 3, 2009
    Location:
    florida
    #3
    i had the same problem with my dlink router also. what i had to do is call dlink and reconfigure all the router settings and now it works fine. so call dlink and tell them you have both mac and windoze machines and they will walk you through the process
     
  4. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #4
    It can be either setting problem or firmware issue. Believe it or not, even with Apple marketshare growing, some routers just don't play nice with Mac/OS X. Had a customer call in with a white MacBook and had problems connecting to his Linksys router in his dorm. His roommate with a PC had no problems. We did the basic troubleshooting to no avail. I suggested that he upgrade the firmware for his router. At the end he was able to connect with no problems. Try upgrading your firmware and hopefully your problems will be solved.
     
  5. mac-raster macrumors newbie

    Joined:
    Mar 30, 2009
    #5
    No DI-624 solution yet

    Thanks to all who have offered suggestions so far.

    1) Tried D-Link online doc - Mac info very old, no improvement
    2) Tried D-Link support email - OS selection stops at 10.4, no reply
    3) Upgraded firmware, no improvement
    4) D-Link wants $$$ for phone support, so I haven't tried that yet

    It occurs to me that this is the only router to which I have tried to connect with WEP encryption. All the others that worked have been open. I wonder if there is something special I have to do on Mac and/or DI-624 side to use WEP?

    XP machines connect OK to same router with WEP.
     
  6. mac-raster macrumors newbie

    Joined:
    Mar 30, 2009
    #6
    Possible solution to DI-624 WiFi problem

    Talked to Apple Care. Tech suggested that I try a significantly different WiFi channel, so I moved from 6 to 1. So far (24 hours), it seems to be working, even with WEP.
     

Share This Page