Bad Wireless Performance Mac OS X 10.5.2

Discussion in 'macOS' started by milesd, Mar 25, 2008.

  1. milesd macrumors newbie

    Joined:
    Aug 8, 2006
    Location:
    Vienna Austria
    #1
    Hello, I have a MacBook Pro (2.2 GHz). After upgrading to 10.5.2 I have
    a very bad performance when using wireless LAN. Safari needs a lot of time to
    load URLs, also downloads are slow. However, when I boot into Vista (Boot Camp) the wireless LAN performance is excellent. Also Ethernet LAN performance (both Vista and Mac OS X 10.5.2) is excellent. Any idea ?
     
  2. HermanTheGerman macrumors member

    Joined:
    Apr 24, 2006
    #2
    Welcome to the club, then.

    I am on a very first generation MBP (Tiger "native"), but also got a new MPB (Leopard "native") lately. I have tried the following steps (on both machines) to get rid of this enigmatic phenomena:

    1. Clean install of Leopard
    2. Router firmware upgrade
    3. Router reset to factory settings
    3. Change of channels on both router and MBP
    4. Adding of the DNS addresses 4.2.2.1 and 4.2.2.2
    5. SSID made visible
    6. Wireless encryption turned off
    6. Install of any software updates available thru software update

    I am able to wirelessly connect to the Internet with both MBPs using either Tiger or Vista.

    Leopard gives me constant drops. Makes it very nasty to chat with people using instant messengers, as you can imagine.

    I have called up Apple support, I have dragged my portables to the closest service provider. Nothing.

    I have searched for help documents in Apple's support section online: Nothing.
     
  3. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #3
    Get the Time Machine Update. It has new Airport drivers.
     
  4. Syrus28 macrumors 6502a

    Syrus28

    Joined:
    Feb 1, 2008
    Location:
    Peoria, AZ
    #4
    Im having the same problems and that did not fix it. About a month ago I would have to constantly go into Network Diagnostics and connect about every 30 minutes. Lately, however, It stays connected but it does not connect automatically to my home network when it awakes from Sleep, but does from Startup. Weird.
     
  5. milesd thread starter macrumors newbie

    Joined:
    Aug 8, 2006
    Location:
    Vienna Austria
    #5
    So as I can see, I am not alone with this problem. I have the latest Time Machine update but it did not help. In my case I do not loose the wireless connection. It's just this terrible performance.
     
  6. Fergus1 macrumors newbie

    Joined:
    Mar 26, 2008
    #6
    I thought the problem might have been the new safari 3.1 update I just installed a couple days ago but this thread makes me wonder what's going on... pages hang upon loading whereas they didn't before the update... most pages are taking 30 - 40 seconds to load that were direct and smooth before with the factory installed software that came on my three week old iMac... it's no wonder I have habitually avoided updates in the past!
     
  7. heatmiser macrumors 68020

    Joined:
    Dec 6, 2007
    #7
    Right on. I used Tiger. 10.4.11. Had rock solid wireless for months. I switched to Leopard, 10.5.1. A few days later, my wireless cuts out, inexplicably. Can't get it to work; finally have to dig up an ethernet cord for the *first* time since I've had the computer, just to get online. Upon reconnecting, I download the Airport update, thinking "this'll fix it". Flash forward a couple of hours and I'm suddenly getting KPs--lots of them. I think "this is crazy", and seriously start thinking of returning to Tiger/Windows. I install 10.5.2, and things settle down.

    Is it any wonder why folks like us keep away from these updates? Not everyone has time to play "what's wrong with my Mac today?" while debugging stuff for Apple. It's particularly hairy when a .x update breaks everything, as the only way to go back to the prior version is to make a completely new installation of the OS, and from there install the .x-1 update. Good times. Right now, I'm on 10.5.2, and there are numerous "security" updates in the software update box, but I'm not going to touch any of them until and unless something goes wrong in my current setup. I've realized I can't trust Apple any more than I could trust MS when they sent me "crucial" updates.
     
  8. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #8
    Another guy a few weeks ago had similar issues, and he reported they went away when he changed his access point security protocol. (None/WEP/WPA/WPA2)
     
  9. milesd thread starter macrumors newbie

    Joined:
    Aug 8, 2006
    Location:
    Vienna Austria
    #9
    OK, I kind of "solved" the problem. I replaced my Netgear router with an Airport Extreme Basestation and now WLAN performance is great with 10.5.2
     
  10. Dudden56 macrumors newbie

    Joined:
    May 21, 2008
    #10
    Difference in uplink and downlink speed

    Having used some broadband speedtests, I have notice that it seems to be the downlink speed that is bad. While uploading I reach 650 kbits per second, which is equal to the restrictions in my ADSL connection, while downloading I only reach 200kbits/s which is far from the max I have in the external connection (4.5 Mbits). Doing the same thing with any of my PC laptops gives me full speed up to the ADSL limitation. Does any one no if WLAN is using differnt frequezes for up and down between the client and the base station, if it is so maybe the Macmini has poor performance on some frequenzies used?
     
  11. dnetmac1 macrumors newbie

    Joined:
    Mar 11, 2009
    #11
    TKIP seems to be related..

    Noticed this problem today across 3 macs running 10.5 somethin :) connected to my wifi net. I was using WPA-PSK with TKIP as my encryption method. After changing this to AES performance was back to normal.
     
  12. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #12
    I'm pretty sure it doesn't matter anymore, seeing as it has been nearly a year and we've had updates since then.
     
  13. dnetmac1 macrumors newbie

    Joined:
    Mar 11, 2009
    #13
    Thanks for nothing

    I hit this forum and it confirmed my suspicions. My 1 month old macbook pro had all of it's updates and still had issues with TKIP enabled. Thanks for your help buddy!
     
  14. tboss macrumors newbie

    Joined:
    Jul 17, 2009
    #14
    What worked for me

    I've been experiencing HORRIBLE performance when connecting my Macbook Pro to a Netgear WGR614 V6. I'm running 10.5.7 and all the latest updates are installed. I flashed the Netgear with the latest firmware. Didn't help. Found this forum while trolling for suggestions last night. What finally fixed the problem for me was disabling 802.11B on the Netgear and leaving only 'G' enabled. I don't know if this will help anybody else, but I post it here just in case it does.
     
  15. tboss macrumors newbie

    Joined:
    Jul 17, 2009
    #15
    Ignore my previous post. Things were better for maybe an hour, but now I'm back to 5-10 bytes per MINUTE throughput. Odd that only the Macbook has problems. XP and Linux(!) work just fine.
     
  16. jackgene macrumors newbie

    Joined:
    Sep 30, 2009
    #16
    I think I may have found a solution to this problem, at least for me. The problem seems to be the wireless adapter's MTU settings.

    It seems the default setting of 1500 is too aggressive. I've tried reducing the number significantly, to 128, and so far, connection stability seems to have improved dramatically (in theory, this is at the expense of throughput). Since higher MTU should result in more throughput, I'm going to try raising this number little by little over the next few weeks until I start seeing problems again.

    To change the MTU settings:
    1. Go to the System Preferences
    2. Select "Network"
    3. Select your wireless network
    4. Click on "Advanced"
    5. Click on "Ethernet"
    6. Select Configure: "Manually", MTU: "Custom", and enter a number lower than 1500
    7. Click "OK" then "Apply"

    Incidentally, I decided to try this when I noticed that the MTU on my Windows laptop was set to 1300. 1300 helped a little bit, but on the Mac, the performance was still pretty bad. So I'm going really low for now.

    Hope this helps.
     
  17. Dudden56 macrumors newbie

    Joined:
    May 21, 2008
    #17
    Thanks and first test OK

    HI and thanks for the reply,

    I have now set the MTU to 500 and it seemed to work fine, I will leave it like that on my sons minimac, and If hasn't complained about the network performance in a week I will see it as a cure,

    It is a bit strange though, my other son who live in the room next door, same distance to the extreme has never had any problems. The cure for the non working computer has so far been that I connected it to a express, used as a bridge, with ethernet cable, and it has worked fine since i did it. So to me it seems unlikely that there is a RF disturbance at a certain frequency that cause the problem as the the other devices should have had same kind of problem, am I thinking correctly here?

    Should i try to optimize for an as big MTU figure as possible or just be happy that it works?

    Best regards Dudden56
     
  18. jackgene macrumors newbie

    Joined:
    Sep 30, 2009
    #18
    I suspect there's more to this problem, and MTU tuning is more of a workaround than anything else. I really hope Apple releases a patch that fixes this eventually.

    As for whether or not to optimize for as big an MTU as possible, that's up to you. I'm going to try it, but right now (at 192), web surfing performance is quite acceptable. The bandwidth (according to speedtest.dslreports.com) is still significantly below what I get on my work (Dell + Windows XP) laptop.
     
  19. Dudden56 macrumors newbie

    Joined:
    May 21, 2008
    #19
    I have continued testing and it seams that performance deteriorates after a while with the MTU set at 500, i will try lower figures, but I agree the problem seems to be more fundamental. I suspect HW problems with the unit.
     
  20. bmh macrumors newbie

    Joined:
    Dec 14, 2009
    #20
    Hi, I just wanted to post Me Too! so that you know you're not alone. I have a Mac Book Pro running OS X 10.5.5 and a Netgear WGR614v6 and I'm experiencing some major issues with DNS look up speed. Once I"m connected to a given server, it works fine, but the initital look up can take anywhere up to 20 seconds.

    I have tried every combination imaginable and am now convinced that it is this wireless router and the wireless link between my laptop that is the problem. I have tried running ethernet cable and it is still the same issue.

    It's weird, because for the longest time, this set up was completely solid, however now it's beyond flakey and nothing has changed. I havent flashed the firmware and I havent upgraded any software on OS X to have caused this problem.

    I'd love to hear any ideas!

    cheers
     
  21. kolax macrumors G3

    Joined:
    Mar 20, 2007
  22. seablue macrumors regular

    Joined:
    Jul 16, 2007
    #22
    Would they not be having all these issues if they did the 10.5.8 update? Isn't that what everyone did or did I miss something here?
    I want to get the new wireless mouse from apple and I see you need to be running on at least 10.5.8 :( And I'm still running on Tiger 10.4.11 So, I was thinking about updating to the 10.5.8 if I can. But after reading all these issues... now I just don't know. My laptop (which I use 99% of the time) is using a linksys router and I sure don't need drop issues.
    Any suggestions??
     
  23. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK

Share This Page