Badge app icon

Discussion in 'iPhone' started by kowen14, Feb 12, 2014.

  1. kowen14 macrumors member

    Joined:
    Oct 26, 2011
    #1
    Whenever I get a new notification the badge icon is never right. One gmail message it shows 3. Same with snapchat, bitesms ..pretty much any app. Any ideas?
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    So, let's say in Gmail example, when you open the app there is only 1 new message and no other ones, despite the badge saying there are 3? Once you leave the app, does the badge remain or it goes away? When a new notification comes in, does the badge once again show an incorrect number?
     
  3. kowen14 thread starter macrumors member

    Joined:
    Oct 26, 2011
    #3
    Correct. There is only 1 message but badge says 3. The badge does go away after I look at that email. Then if I get another email the badge will say 3 again.

    ----------

    Right now I have 1 app update but the badge is saying 3. I update the one app and the badge is gone
     
  4. mofunk macrumors 68000

    mofunk

    Joined:
    Aug 26, 2009
    Location:
    Americas
    #4
    Could it be that you have a spam mail? I know when I get spam sent to my Mac mail the number will show up.

    On Gmail some of the messages are slow to load when I'm on wifi… I simple refresh the thread or close out the app.

    Check those..and see if it works.
     
  5. kowen14 thread starter macrumors member

    Joined:
    Oct 26, 2011
    #5
    Nothing to do with spam. Happening with other apps also.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Any chance those apps might have more than one item that is new as well (just perhaps not easily noticeable, like an older email somewhere or an older message)? Or is it essentially all apps that always have extra numbers listed in the badges fairly consistently?
     
  7. mofunk macrumors 68000

    mofunk

    Joined:
    Aug 26, 2009
    Location:
    Americas
    #7

    You're not listening. lol j/k It happens to me when I get spam in my Mac mail spam folder. That's the only time I see it with mac mail. The other times is with Gmail. I'm guessing the incoming gets hung up somewhere. or it could be iOS7 acting up.

    There are a few other apps I have too that do that. Waze and a few gaming apps.
     

Share This Page