Badges not clearing on Mail.app

Discussion in 'iPhone Tips, Help and Troubleshooting' started by CDutch, Mar 21, 2011.

  1. CDutch macrumors regular

    Joined:
    Jul 6, 2009
    #1
    For starters, the account I'm having trouble with is my work exchange 2007 account.

    Basically, I'm having an issue where the notification badges are not clearing from the mail.app icon despite having already viewed the email on my computer. New mail will push to my phone instantaneously but for some reason, the badge does not clear if the email is read in Outlook...it's as if it is only pushing new mail but not fully syncing unless I open the mail.app application on my iPhone.

    Any suggestions?
     
  2. rdowty macrumors 6502a

    rdowty

    Joined:
    Oct 5, 2008
    #2
    I think that's exactly what it does.
     
  3. CDutch thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #3
    For my gmail account, the badge disappears pretty much instantaneously after I view an unread email on the gmail website. I assume the behavior should be the same for my work account.
     
  4. /user/me macrumors 6502

    Joined:
    Feb 28, 2011
    #4
    If you refresh your mail.app this should take care of the issue. I have noticed that it does this with my campus mail server (imap). When I refresh my mail.app, it syncs correctly, and the badge disappears.
     
  5. CDutch thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #5
    Right...but if you're using an exchange account, you shouldn't have to open and refresh mail.app. That's the whole point of ActiveSync...or at least that was my understanding.
     
  6. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #6
    I am going nuts with my Google Exchange account not working correctly. I am not getting push notifications in a timely manner. When I recieve an email in gmail my iP4 (iOS4.3) sometimes won't show the message for 20, 30, 60, etc. minutes. If I reset my iP4 then as soon as it finishes the reboot I get all the messages. The funny thing is my imap Yahoo account works fine. I have done a CLEAN restore and that has not fixed the problem. My conclusion is iOS isn't playing nice with Exchange.
     
  7. /user/me macrumors 6502

    Joined:
    Feb 28, 2011
    #7

    Right, I understand that. I'm just stating that I have had a similar problem with my account. Granted they're not the same format, but the two issues could be related.
     
  8. CDutch thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #8
    Any other suggestions?

    It's weird. I have two Exchange email accounts on my phone. My work account and my Gmail account. Both are set to "push" so they should synchronize automatically. With my Gmail account, when I view an unread email on the Gmail website, the new mail notification on my phone disappears within seconds. For some reason, that's not happening with the work account.

    Just seems odd that they don't behave similarly.
     
  9. vasska macrumors newbie

    Joined:
    Aug 20, 2011
    #9
    badge won't clear, even if i launch mail app

    my iphone 3gs has recently developed a related problem, where the new mail badge does not clear even if i already read the email on my computer. but the badge persists even if i open the app. FYI, the email account in question is a microsoft exchange account with push enabled.

    i tried switching to fetch, and back to push, with no avail. restarting the iphone also had no effect.

    it's a serious nuisance since i receive 20-100 work-related emails per day, and manually going through them on the iphone after i have already read them at my desk is a serious pain.
     
  10. meemster macrumors newbie

    Joined:
    Oct 19, 2011
    #10
    I have the same problem

    I have the same problem as Vasska and I've updated to iOS 5. Bump.
     
  11. hyperpiper45 macrumors regular

    Joined:
    Dec 11, 2007
    Location:
    Calgary, Canada
    #11
    I just wanted to bump this thread as I am having exactly the same problem as CDutch. I am using iCloud and I get new e-mails straight away but if I read them on Mail on my Mac the icon still stays on my phone until I open the app.
     

Share This Page