Baffled by Boot Camp: Black Screen

Discussion in 'Windows, Linux & Others on the Mac' started by psikahn, Jul 2, 2007.

  1. psikahn macrumors newbie

    Joined:
    Jul 2, 2007
    #1
    Hey folks,
    I've encountered an interesting, if not incredibly frustrating, problem on my Macbook Pro and I was hoping someone might be able to help me diagnose and rectify it.
    I had installed XP via Boot Camp 1.1 in August successfully and used my XP partition for a few months. Then, one day, when I went to boot into XP, after selecting my XP partition at the startup screen, my computer went to a black screen with no cursor or error message. I had no idea what to do, so I decided to simply delete my partition and create a new one and reinstall Windows. After deleting it and firing up Boot Camp, I encountered the very same black screen when Boot Camp restarted my computer. It would go to the grey startup screen first, but then to a black screen. The XP install disc would seemingly spin up properly, but nothing ever showed on screen. I then tried any number of possible fixes, including zeroing my entire hard disc and reinstalling OS X and Boot Camp (now 1.3), but have had the same result each time.
    I have begun to suspect that the problem is related to the EFI, but I don't know very much about that sort of things and don't really know how to adjust its settings or reinstall it. I've downloaded the most recent EFI firmware, but when I try to open the file OS X insists that my firmware is already up to date.
    Any ideas would be a big help, I've been scouring the internet for the last couple weeks and am yet to come up with a solution. Thanks!
     
  2. dcl macrumors regular

    dcl

    Joined:
    May 28, 2006
    Location:
    Calif.
    #2
    psikahn,

    Started last few months having the same problems.
    If it doesn't do anything for a 5 minute, I'll just turn off the macbook.

    I'll go for a dozen startups in windows with no black screen, and sometimes takes turning of the mac a few times before it goes through.

    I don't think it has really hurt anything, and I believe it is more of a problem with XP than with bootcamp or the macbook. I experienced this type of stuff alot on the PC before going Mac.

    After you boot up, just run a checkdisk in XP to see if there are any damaged files or sectors on hard drive
     
  3. psikahn thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #3
    DCL,
    Thanks for your tip, but that doesn't seem to be working. I've tried to get the installer to kick up at least 25 times and have yet to see any success. Sometimes after a while it will at least show the XP installer and a "Windows" disc drive option separately in the boot menu.
     
  4. steveh518 macrumors newbie

    Joined:
    Dec 25, 2007
    #4
    blackscreen after booting

    i load up windows on my macbook, after my desktop comes up. soon after the screen goes black. whats going on?!
    i want to uninstall windows then reinstall it. how do i go about doing that?
    thanks
     
  5. dopalgangr macrumors newbie

    Joined:
    Sep 13, 2010
    #5
    I have the same problem on my mac. It has been working for a year or so and now all of a sudden it will not boot into my Vista installaton nor can I boot from the Windows CD or a Bart PE CD, however if I hold opt key I can choose the OSX partition and boot into there with no problem? I even see the BOOTCAMP partition and can browse the files? Hasa anyone ever figured out how to fix this?
     
  6. Yatteri macrumors newbie

    Joined:
    Dec 12, 2010
    #6
    I'm having the same problem. My partition has been working perfectly fine for the last 12 months. I'm on a MacBookPro 10.5.8

    Last night I tried to boot into it and I got the blinking underscore in the top left of a black/blank screen.

    I've tried booting from my MAC OSX Install DVD (never works for me) I've tried booting from Windows Vista Recovery Disk, from Windows XP Install Disc, and from the Windows Vista Upgrade disc i used to upgrade my windows partition from XP -> Vista.

    In MAC OSX I put in my Mac Install DVD and nothing happens... it just automatically ejects. When I put in my WinXP Install disc it says I have inserted a blank disc. when I put it into my desktop PC the Windows XP install screen comes up...

    No idea how to fix. I've tried resetting PRAM but nothing.
     
  7. HadItWithWindow macrumors regular

    Joined:
    Dec 1, 2008
    #7
    Same Problem Here All Of A Sudden

    Did you recently do the update of Bootcamp? I'm thinking that is when my booting problems started. I run Windows7 on Bootcamp. I forget which side (Windows or Mac) offerred the updating to Bootcamp but i selected the update and wished I hadn't.
     
  8. Yatteri macrumors newbie

    Joined:
    Dec 12, 2010
    #8
    I personally didn't have any updates to bootcamp in either windows vista or on my OSX, it just sort of quit on me randomly...
     
  9. gibson00 macrumors newbie

    Joined:
    Jan 15, 2010
    #9
    Hi all, I know this is an older thread, but did anyone ever figure this out?? I bought my new MBP in June 2010, successfully installed Windows 7 with Bootcamp and it has been working ever since.
    This morning, I boot to windows and it does the same as some of you described, goes to a black screen. Sometimes if I reboot by holding the power button down, then hit again to power up, it will take me to the boot screen where it asks if I want to boot into windows safe mode. If I choose safe mode, it does successfully boot into that.
    I'm wondering if there is a display driver issue?

    Thx!
     

Share This Page