Base SDK features v older devices

Discussion in 'iOS Programming' started by thedollarhunter, Nov 29, 2011.

  1. thedollarhunter macrumors member

    Joined:
    May 9, 2011
    Location:
    UK
    #1
    Just wondering what base SDK is most popular and why?

    I noticed Minecraft required 4.3 but could not face updating my iPad so didn't bother with it, which got me thinking! (doesn't take much).

    At the moment I am using 4.2

    I only use simple features of GameCenter, OpenGL 1.0 ES and IAP.

    I would like to run my app on 2nd generation iPod etc (these can get iOS 4.2 i think?)

    :confused: MJ
     
  2. ArtOfWarfare macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #2
    Whichever one is the oldest that can support your app.

    Taking advantage of features like Game Center doesn't actually force you to make your base 4.2... You could have just a little if-else in your code that says if GC is available, use it, and if not, don't bother. I'd suspect GC isn't exactly a core requirement for your app.
     
  3. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #3
    My recent projects are coded to support as far back as iOS 4.0.
     
  4. North Bronson macrumors 6502

    Joined:
    Oct 31, 2007
    Location:
    San José
    #4
    Remember to distinguish between your application's Base SDK and your application's Deployment Target. Always build your application from the latest SDK and set the deployment target to the lowest version you want to support.

    The latest version of Xcode that I have only wants to build for armv7, which would leave out the Second-Generation touch and old iPhones.
     
  5. jnoxx macrumors 65816

    jnoxx

    Joined:
    Dec 29, 2010
    Location:
    Aartselaar // Antwerp // Belgium
    #5
    You are talking about 4.2
    are you sure, you don't mean the Xcode version vs iOS.
    I'm not saying you are wrong, just there is a difference.
    To backwards compatability, i allways go back to 4.0, since alot of the devices are still running 4.x, specially iPads.
     

Share This Page