Baseband version after jailbreak and unlock

Discussion in 'Jailbreaks and iOS Hacks' started by Rxiesling, Feb 14, 2008.

  1. Rxiesling macrumors newbie

    Joined:
    Nov 15, 2007
    #1
    I just ran iJailbreak 0.5.3 and unlocked my phone. Everything seems fine, but baseband becomes 04.02.13_G. I remembered it used to be 04.03.13_G. Is this normal? Any potential problems? My iPhone was bought new a month ago with 1.1.2 and upgraded to 1.1.3 before iJailbreak.
    Thank you.
     
  2. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #2
    The unlock for 1.1.3 requires using a modified version of the earlier baseband 4.2.13_G. It's normal, but that's why the Maps locate me function doesn't work properly without a workaround.
     
  3. kbonnel macrumors 6502

    Joined:
    Mar 1, 2004
    Location:
    In a nice place..
    #3
    Hi,

    munroe is spot on. If the phone has the 4.6 BL, then the unlock method for 1.1.3 phones is to use a 04.02.13_G modem baseband firmware since the 04.03.13_G verion is not unlockable at this time under the 4.6 BL. If the phone has the 3.9 BL, then the 1.1.3 phones will use the 04.03.13_G modem baseband firmware since it was unlockable due to the secpack issue.
     
  4. Rxiesling thread starter macrumors newbie

    Joined:
    Nov 15, 2007
    #4
    Thank you.
    So far the only problem is Google Map location.
    If I want to undo jailbreak and unlock, can I just restore from iTunes and get the baseband back to 4.03.13_G?
     
  5. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #5
    Yeah, you'll have to get the iPhone in restore mode to to get iTunes to replace the baseband and firmware, but that's the general idea.
     
  6. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
    #6
    hmm.. so i upgraded my otb 1.0.2 iphone to 1.1.3 in itunes and then used ziPhone 2.0 to jailbreak/activate/unlock and my iPhone now has modem firmware: 04.03.13_G

    My phone used to have the 3.9BL, does this mean its now using the 4.6 BL?

    Thanks
     
  7. kbonnel macrumors 6502

    Joined:
    Mar 1, 2004
    Location:
    In a nice place..
    #7
    Hi,

    No, your phone is still 3.9BL, as it is my understanding that NO Apple update will touch the BL. There is a way to downgrade the 4.6 BL to 3.9 BL though, but I have never done it, and don't know the risks involved. The BL (Boot Loader) is not the same as the Modem Firmware.

    Kimo
     
  8. cpostier macrumors newbie

    Joined:
    Jun 5, 2007
    #8
    unlock

    I just upgraded to 1.1.4, then restored to 1.1.3 so i could use ziphone and unlock, i had a iphone with 1.0.2 used anysim and unlocked and worked fine for months...

    Now it says I have BaseBand 04.04.05_G

    Not sure what bootloader i have.

    Now, i run the unlock and it says it ran alright using iNdependance, but i still get no service on my had been working tmobile sim

    please help..!!! What do i do to downgrade firmware? baseband?? install 1.1.2?
     

Share This Page