basic formulas do not work when opening Excel files in Numbers?

Discussion in 'Mac Apps and Mac App Store' started by stanw, May 14, 2014.

  1. stanw macrumors 6502a

    Joined:
    Aug 29, 2007
    #1
    I have an Excel spreadsheet that was given to me to input data. It is setup to add different cells together. I copied and pasted info into it, quantity, and price amounts, though afterwards, I get error messages (see attached error message). I tried changing the formatting of the cells to currency though that didn't work. One row strangely did add up. I'm attaching screen captures. Anyone know why it doesn't work?

    Thanks.
     

    Attached Files:

  2. Palladium macrumors member

    Joined:
    Jan 2, 2006
    Location:
    Northern Ireland, UK
    #2
    Hi,

    From the error message, I deduce the data values you are pasting in are represented as text rather than as numbers, though why one row is different I don't know.
    Also to be pedantic, the portion of the spreadsheet shown is not adding any cells together. It is set to multiply the cost of each item (figure in 3rd cell from the left on the each line) by the numbers of that item (figure in the leftmost cell on each line). The rightmost cell where the result should appear, will contain a formula such as = a1*c1. The multiplication operator '*' cannot handle text strings.
    I would think that either all the cells into which you are inputting data have been set to treat input as text by default or that somehow you are lifting the data to be pasted as a text string, i.e. simply as a sequence of characters.
     
  3. stanw thread starter macrumors 6502a

    Joined:
    Aug 29, 2007
    #3
    How can I get Pages to acknowledge the info as numbers and not text? I keep changing the text in the cells to currency, is there some other setting I can try or is this spreadsheet just messed up at this point?

    And yes, I meant to say the spreadsheet was multiplying the cells, I posted this late last night.

    Thank you.
     
  4. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #4
    Title of thread says Numbers. Your post says Pages. Which one? If Numbers, just select columns and change them to Automatic or Currency or Number. Ensure that there isn't a ' (apostrophe) in the cell (you won't see in cell but will see when in formula bar when you click on cell).
     

Share This Page