Battery drain for iPhone 4; usage = standby

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Luminyx, Oct 8, 2010.

  1. Luminyx macrumors member

    Joined:
    Jun 25, 2010
    #1
    I've had my iPhone since the day it came out and battery hasn't been a huge concern. Very recently, I noticed it's dying very quickly. It must have gone down about 40% overnight, and then I realized my standby and usage time are the same. I didn't leave anything unusual on overnight either. I tried closing ALL things in multitasking, yet usage still increased when standby increased. Restarting the phone "fixed" the problem. I started to use it again and checked my usage vs standby later: 15 hours 2 minutes vs 15 hours 6 minutes. The problem is back, and again I didn't use or open anything unusual. What could my problem be? FYI, my phone is jailbroken.

    EDIT
    Also, I'm running iOS4. No updates.
    [​IMG]
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Sounds like a rogue app. Try troubleshooting your MobileSubstrate add-ons. One of them is obviously running down the battery. The Signal app is known for doing this.
     
  3. ashVID macrumors regular

    Joined:
    Jun 30, 2007
    #3
    Same issue, no jailbreak, latest firmware, started a couple days ago. The ONLY thing I did was log in to the game center, didn't play, didn't do ANYTHING with it and turned off all alerts and push concerning it. Might be unrelated but I'm currently losing 15% an hour on standby. I DO have MobileMe but nothing happens at night, and that has been the same all along. Always had GREAT battery life.

    Curious



    ash =o)
     
  4. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #4
    I also experience the same behavior but not every day. I would say that th problem happens once or twice a week and a reboot solves the issue temporarily. I think that it happens when I use apps that download stuff, like Reeder, Facebook or background apps like Skype.
     
  5. cathyy macrumors 6502a

    Joined:
    Apr 12, 2008
    #5
    I've noticed this several times. I usually need to do a hard reboot in order to fix it.
     
  6. petegas macrumors newbie

    Joined:
    Aug 28, 2008
    #6
    Same here - iphone 4, no jailbreak, everything up to date. It would be nice to have a taskmanager.
     
  7. PedalheadPHX macrumors newbie

    Joined:
    Oct 22, 2010
    #7
    I've got the same problem, I think since the new iOS release. Actually had my phone replaced at the apple store after a week of trying hard reset, then restore from back-up, then restore as new phone. Now new phone built up as a new phone has the same issue. Oddly, my wife's phone tied to the same computer, neither broken and kept updated, does not have this problem. I kill all apps manually and the phone is dead in 5-8 hours with no usage but usage and standby time are nearly identical.
     
  8. patrick1234 macrumors member

    Joined:
    Oct 28, 2008
    #8
    some people says the game center is the bug, it works allways in background!
     
  9. Macnator macrumors 6502

    Joined:
    Jan 25, 2008
    Location:
    Canada
    #9
    I have basically the same thing. 32GB iPhone 4.

    Just recently, about 2 days ago, I noticed that my battery was draining ridiculously fast, much, much faster than before.

    I had two instances where Usage and Standby both were 8 hours, and one was 9 hours for both.

    Last night I left my iPhone on when I went to sleep with about 75% battery left. I woke up to use it and it was completely dead. It showed the red battery symbol thingy telling me it needed to be plugged in.

    What the hell is happening?:confused::confused: I had amazing battery life up until 3 days ago.

    I've been using my iPhone 4 for about 2 hours now, and I'm at 63%. Horrible! Before it would be at like 80%+ after 2 hours.

    Also, it's getting really warm while charging and I don't remember that happening before.
     
  10. b3ngal macrumors newbie

    Joined:
    Jan 6, 2011
    #10
    The problem might be mobile me find my phone service... After I turned that off and removed all the apps off my task list problem seems to be solved
     
  11. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #11
    It happens as well on my factory unlocked iPhone 4 (4.2.1) every now and then (actually it just happened - about 3 weeks after it last occurred).

    I really have no idea what the culprit could be, but apparently not Game Center, as I haven't used it in a long time (and it's not among my used apps in the multitasking section either).

    I don't think it could be the Find Phone app either because I usually keep Cellular Data OFF - unless temporarily turning it ON could trigger some irregularities within the phone battery meter or whatever, but I doubt it...? But on a second thought though, I'm usually connected to Wi-fi, so I guess that would be the same as keeping Cellular Data ON, which prevents me from ruling this app out. Hm.

    What else could it be though? Someone has mentioned Skype, which I haven't used in a while, so I would rule it out in my case. Which leaves me with either eBuddy or Facebook; I'm using the latter every day, while eBuddy... Well I used it a couple of days ago, but as far as I remember I manually quit it too! (From the multitasking window).

    It seems that it's been occurring only on 4.2.1, as I don't remember it happening on 4.1. I hope they fix it in 4.3; it's getting kind of annoying.
     
  12. mkisawesome macrumors newbie

    Joined:
    Aug 14, 2011
    #12
    Extremely loss of Battery life in iPhone 4

    Often applications fail proper installation and a process can hang, causuing repetitive instruction calls (even in standby). With such a process continuously running on your iPhone, the battery drain can be significant - up to 25% or more in an hour. Here are a few solutions that have worked for me (it's happened to me on three separate handsets of the iPhone - especially the usage time = standby):

    1) Do a hard reset - Hold the home and sleep buttons down together for approximately 10 seconds until the phone turns off. Wait a few second, then repeat to turn it back on. THIS WILL NOT ERASE any of your data or lose any of your setting, rather just a flash memory reset.

    2) If that does not solve the problem, follow this procedure:

    1. Under Settings, go to Mail/Contacts/Calendar - tap the name of the
    Exchange account. You will see 3 switches. Turn them off (repeat for
    each account), then back out of Settings. Do not turn off PUSH; only turn
    off the 3 switches. You may receive warning messages - go ahead and
    accept these - this data will be restored from your accounts once the
    switches are turned back on.

    2. Open the apps one at a time, first Mail, then Contacts, then Calendar
    so these apps apply the changes.

    3. Hold the home button for a few seconds and close all multitasking apps,

    4. Turn off your phone, wait a few seconds, then turn it back on,

    5. Go back into Settings and turn the 3 switches back on.

    Usually the hard reset will solve the problem on its own, but the mail reset may be necessary in cases where the mail application is causing the process error.

    Good luck!
     

Share This Page