Battery dying rapidly on standby.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jekyoo, Sep 19, 2010.

  1. jekyoo macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #1
    [​IMG]

    [​IMG]

    Recently my iPhone 4 have been dying very quickly where I'm getting worst battery life than my original 3GS. So I decided to test it and purely put my phone on standby with almost no use and I'm getting these horrible numbers. Is anyone experiencing this type of horrible battery life? Possibly a defected battery?

    The iPhone has nothing installed w/ factory settings. Only thing I've added was my email account.
     
  2. AppleCode macrumors regular

    AppleCode

    Joined:
    Jul 28, 2010
    #2
    Do you hav lots of apps running n the background. If not it may be a battery failure.
     
  3. jekyoo thread starter macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #3
    the only app running in the background is probably settings since i changed my usage/standby once every couple of hours.
     
  4. diamond.g macrumors 603

    diamond.g

    Joined:
    Mar 20, 2007
    Location:
    Virginia
    #4
    What kind of mail account?
     
  5. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #5
    Yes, if you have mail fetch turned on, that's going to eat battery, as fetch still occurs in suspend. Use either manual fetch or push (push also eats battery, but probably not as much as frequent fetching does).
     
  6. jekyoo thread starter macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #6
    My mail account is set to push / fetch manually.

    Even if it was pushed every 30 mins, it shouldn't die soo quickly.
     
  7. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #7
    Well, the only other thing that comes to mind is your "No SIM" display. Do you really have no SIM? This is reaching, but maybe there's some issue where, if you have no SIM, the iPhone fires up the transceiver way too much, draining your battery.
     
  8. jekyoo thread starter macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #8
    it's my spare iphone 4 so there isn't a sim in it at all, there is never a sim in it but the battery just dies rapidly :( i really don't want to get this phone replaced since it's on 4.0.1 :(
     
  9. m3coolpix macrumors 6502a

    m3coolpix

    Joined:
    Dec 24, 2007
    #9
    If this is a stock software iP4 (not jailbroken), then you really only have 2-3 choices.

    1-replace the battery yourself
    2-take it in for exchange
    3-restore to stock 4.1 software

    IF you were jailbroken, AND you have the 4.0.1 shsh saved, then you could restore back to 4.0.1.
     
  10. bnr macrumors newbie

    Joined:
    Sep 21, 2010
    #10
    how to find out the apps that are running in background? sorry for silly question!!

     
  11. jekyoo thread starter macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #11
    1. definitely not gonna do one since it's just a total waste of $$.
    2. i don't wanna exchange it since all the new iphones are on 4.0.2+
    3. don't wanna go to 4.1 right now since there is no jailbreak for it.
     
  12. jekyoo thread starter macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #12
    press the hold button twice @ the homescreen.
     
  13. diamond.g macrumors 603

    diamond.g

    Joined:
    Mar 20, 2007
    Location:
    Virginia
    #13
    My wife had a similar battery problem, turns out it was her exchange mail that was draining the battery faster. Made the account inactive and things are back to normal!
     
  14. mr-kenneth-man macrumors newbie

    Joined:
    Sep 14, 2010
    #14
    My recent experience:

    My push settings are enabled for 1 hotmail and 1 gmail account whereby they both push the inbox only. Fetch is enabled every 30minutes.

    I've been late for work twice this week. My phone is on charges all day, however is not on charge when i go to sleep. It is usually between 96-100% battery prior to going to sleep, however in the morning it's turned itself off and I have to charge it for it to turn on again. I check the usage in settings and the usage is close to that of standby - suggesting that it's been in use through the night.

    I've not had an issue with it prior to enabling push for hotmail and have closed all apps in the springboard. My iPhone 4 is using iOS 4.1 and is not JB.

    During the day, I take my phone off charge for an hours testing and keep note on the usage. The usage seems normal, my battery drops a few %, standby is about 1 hour and usage is about 10minutes.

    Any suggestions on how to fix this? Any one else having similar issues?

    I've changed a few settings and left push on for my gmail account, however have changed my hotmail to fetch every 30min.

    This is copied from another thread, but thought it was relevant for both.
     
  15. AlyMourad macrumors member

    AlyMourad

    Joined:
    Oct 22, 2007
    #15

    I had the same problem few times already on my iPhone 4 as well. and each time it was fixed by the following steps:


    1) Go to Settings -> General -> Reset -> Reset Network Settings

    then when its done rebooting on its own

    2) Reboot the iPhone again by holding the home and power button for few seconds till it shuts down and power on again.

    (don't forget to setup your wifi & custom networks settings again)
     
  16. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #16
    If you're accessing hotmail via MS exchange, you don't need fetch (and I'm not sure fetch makes a difference in this case). If you aren't using MS exchange for hotmail, you don't have push for that. Still, unless you're sleeping in a area with no/poor wifi and poor 3G (or are putting the iPhone into a place with poor signal, like a metal box), I don't see how fetch can drain your battery overnight, although it would eat battery.

    (And I'm assuming that you're already using MS exchange to access gmail, since you claim to have push for it.)
     
  17. mr-kenneth-man macrumors newbie

    Joined:
    Sep 14, 2010
    #17
    I'm using MS Exchange for both Hotmail and Gmail.

    I have a very strong wifi signal and a very good GPRS connection (no 3G where I live). Wifi is always enabled. My phone is on the floor next to my bed during the night as I don't have a side table and a plug socket close enough to charge it over night.

    I thought that push would "fetch" any emails that were sent to my inbox immediately, whereas fetch would "fetch" any emails every 30 minutes in my case.

    I have noticed that when I'm using my ipod dock, I hear interference (which is usual when sending and receiving data from my phone) when I receive texts, phone calls, notifications or every 30min when my emails are "fetched". Since having the battery drain issue, the interferance is much more frequent and can last a good 15 mniutes with little interval each time. This suggests that the phone is almost constantly sending/receiving data....hence the high usage statistics and dead battery in the morning!
     
  18. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #18
    If you only have exchange-based accounts, you should just turn off fetch (set it to manual). If there are other folders, besides your inbox, that you want pushed, just go into the iphone's mail settings and mark the additional folders that you want.
     
  19. mr-kenneth-man macrumors newbie

    Joined:
    Sep 14, 2010
    #19
    But surely I want my emails to be fetched so that the number of new emails is shown rather than manually checking the mail app. I'd be spending my day checking for mail, when I only need to go into mail when I have a new mail. I've turned push off and left fetch on for hotmail and battery seems to be improved....but only time will tell.
     
  20. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #20
    Huh? That's a bit backwards.

    With push, the number gets updated on-the-fly (for those folders for which you have enabled push). It's pretty cool to bring up the iPhone's home screen (which, on mine, shows the total number of unread messages), delete a message via my desktop PC, and then watch the number dynamically update a moment later on the iPhone. Note that, on my iPhone, I do NOT have the mail app open. With push, I don't have to enable slow fetch, and I don't have to constantly check for new email manually.
     
  21. jekyoo thread starter macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #21
    I don't use exchange, it's just google set to manually fetch.
     
  22. jekyoo thread starter macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago
    #22
    I'll try this out and report back.
     
  23. mr-kenneth-man macrumors newbie

    Joined:
    Sep 14, 2010
    #23
    I think i mis-understood your previous message.

    The problem I was having was that push was draining my battery, therefore having push was no good, therefore I opted for fetch. I've seen that deleting or receiving an email on pc/mac is also displayed simultaneously as on the iPhone with push enabled.

    I had both fetch and push enabled as I had four accounts, where two used push and two used fetch (due to restrictions). I've now decided that the two accounts with a lack of push can be removed as they are used infrequently. Therefore I now have 1 hotmail and 1 gmail account, both using microsoft exchange and push enabled with all folders using this option. I do however also have gmail set up again using fetch as microsoft exchange doesn't allow me the option to sync my notes app, whereas using smtp does.

    To summarise, push is on by default for email and fetch is set to manual (as suggested). I will try this set-up and see whether this increases battery performance!

    Thank you for the help!
     
  24. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #24
    If you still have problems, try AlyMourad's solution in post #15 above, if you haven't already. Note that you will have to re-enter all of your wifi settings, for each and every one of the access points that you use.

    Edit: Also, are you telling exchange to synchronize all mail (as opposed to the past month or less)? I have seen an issue with large folders where, if you try to view a large folder, the iPhone will synchronize the entire folder, even though you may have stopped viewing the folder and have gone off to do something else. If the folder is big (like gmail's "All Mail"), the iPhone will slowly synchronize the entire folder, and suck your battery dry (you did say, "all mail", after all). Strangely enough, I've only seen this behavior when viewing a folder (I'd expect the iPhone to just blindly synchronize all folders, instead of just when you view them, but I suppose that would really suck the battery dry).
     

Share This Page