Battery failed, and now new one won't charge!

Discussion in 'MacBook' started by rameenmachine, Sep 11, 2010.

  1. rameenmachine macrumors newbie

    Sep 11, 2010
    hi all. so after scouring the internet, i realize that i'm just another dude with macbook battery problems. My old battery died, i got the x of death, and i tried another charger, which didn't help. i then bought a third-party battery from ebay, which had a bit of charge on it, but when i put it in the computer, it says "not charging." I'm trying not to get totally frustrated, but i really can't figure out what else to do. I've downloaded the battery updates, I've tried to follow directions on other threads, but nothing has seemed to work so far. any suggestions? I'm not under applecare so i don't know if taking it to the store would even help.

    9/12/10 update:
    so I turned the computer on this morning, and it said the battery was charging, and that it would be about 2:15 to complete the charge. 2+ hours later, I come back to the computer (after intending to let it charge up all the way and then let it die), and despite that the battery's now at 86%, it still said it'd need another 2 hours to finish. I stupidly unplugged the charger and plugged it back in, and now of course it won't charge again. I'm back to the Not Charging problem, and resetting the computer didn't fix it. Any suggestions? Any and all help is much appreciated!
  2. BigTroll macrumors member

    Mar 21, 2010
    not sure what model your macbook is but the older ones have logic board issues where they wont charge and sometimes not recognize the battery anymore. i would try and find a friend with the same model macbook and try his unit to charge your batteries and also try his a/c adapter on yours and see if that helps. but besides resetting the Power Management Unit, PRAM etc. its probably a logic board issue... I hope all turns out well ;)
  3. AlphaDogg macrumors 68040


    May 20, 2010
    Boulder, CO
    Check the magsafe port's position in the case. My friend has a unibody MB, and the magsafe port became loose within the computer, and of course, it would not charge. It said (battery is not charging) where the battery indicator is normally located.
  4. Naked Snake macrumors member

    Jul 2, 2008
    Los Angeles,CA
    I'm having the same issue. My 13' Aluminum Macbook just wont charge at all anymore. it just stopped charging completely. Could it be my charger just gave up or my Macbook battery died? It's been only 2 years.

Share This Page