Battery "glow" issue sort of

SaleenS351

macrumors 6502
Original poster
Dec 2, 2004
287
0
California
Hate to to start a new thread on this, but my return period is ending soon. Any way here it is:

When I first charged my battery, I didn't get the "glow" this was via AC. with about a 95% charge, 5% left to go that just wouldn;t move, I had usage and stand by both reading 2hr 16min. Got to work hooked it up to my macbook pro via USB and did a hard reset and when it came back on line I had the "glow" and both stats were reading correctly again.

Next night tried the AC charge again same result, tried a hard reset while connected to the AC, nothing. Switched to my powermac via USB and did a hard reset and got the "glow".

Any ideas on what's going on here? Wait it out for an update? I don't mind charging it through my computers via USB, but that shouldn't be the way it is, eventually I will be on vacation or somewhere where I need to charge via AC. I don't really want to exchange it if at all possible, since the phone does seem pretty good other than that and I am getting good battery life once the "glow" appears. Any thoughts would be greatly appreciated.
 

r6girl

Administrator/Editor
Staff member
Sep 6, 2003
1,726
47
Massachusetts
your AC adapter may simply not be working anymore. mine stopped working and i made an appointment with a genius at a local store, and they swapped it for a new one, no questions asked, immediately.

no need to exchange your phone if it's just the ac adapter. there's a thread on this problem on another forum i've been reading here...
 

iRabbit

macrumors 6502
Jul 10, 2007
438
33
Hate to to start a new thread on this, but my return period is ending soon. Any way here it is:

When I first charged my battery, I didn't get the "glow" this was via AC. with about a 95% charge, 5% left to go that just wouldn;t move, I had usage and stand by both reading 2hr 16min. Got to work hooked it up to my macbook pro via USB and did a hard reset and when it came back on line I had the "glow" and both stats were reading correctly again.

Next night tried the AC charge again same result, tried a hard reset while connected to the AC, nothing. Switched to my powermac via USB and did a hard reset and got the "glow".
I've never gotten the glow...

What do you mean by a hard reset? And do you do the hard reset while it is connected to the dock?
 

SaleenS351

macrumors 6502
Original poster
Dec 2, 2004
287
0
California
It does charge through the AC but not the last 5 or so %. By hard reset I mean I'm holding down the home and screen sleep button at the same time while plugged into the computer then I get a full charge.
 

iRabbit

macrumors 6502
Jul 10, 2007
438
33
It does charge through the AC but not the last 5 or so %. By hard reset I mean I'm holding down the home and screen sleep button at the same time while plugged into the computer then I get a full charge.
I've tried a lot of different things to get the battery glow, but I'm not sure if I've actually tried a hard reset while it's ON the dock, so I'll give that a try and see if I get the same results as you.

For what it's worth, I've never had "the glow" - always have that last little sliver not filling in... but I am getting excellent battery life.
 

unity

macrumors 6502a
Sep 30, 2005
926
0
Green Bay, WI
Read this?

http://www.apple.com/batteries

If you read it, you can see that the last part of the charge takes the longest. I am not saying that is you problem, but mine can easily take 2 hours to finish off.

Also, try a "calibration". Dont do it often, but drain to 10 or even 5 percent, then let it fully charge without unplugging it. Try to have it off to if you can, or at least in airplane mode.
 

SaleenS351

macrumors 6502
Original poster
Dec 2, 2004
287
0
California
I may be wrong but I was under the impression that u can't charge while it is off i may be completely wrong. I may try to call apple and see what they have to say.