Battery indicator strangeness? (NOT another battery complaint thread!)

Discussion in 'iPhone' started by rotobadger, Jun 27, 2009.

  1. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #1
    I'm wondering if anyone else has seen this. When I first got my 3GS I was not thrilled with battery life (as indicated by the percentage) but was not really that worried. When I woke up in the morning it seemed to drop at a rate of 1 percent every couple of minutes of active use (web browsing). Then, a couple of days later, I did a partial charge of my phone (to sync some stuff) and then noticed the battery meter was hardly moving at all! Weird.

    Everything seemed to be going great. Then, this morning, after taking the phone off the charger, the meter started dropping quickly again. I was at 97% in about 7 minutes. I then restarted my phone and...the meter is back up to 100%! And it seems to be working correctly again.

    So maybe its not the battery but simply a software glitch?

    Still love my new 3GS!
     
  2. cmaier macrumors G3

    Joined:
    Jul 25, 2007
    Location:
    California
    #2
    could be a calibration issue
     
  3. TheNewsPaperBoy macrumors regular

    TheNewsPaperBoy

    Joined:
    May 10, 2009
    Location:
    Florida
    #3
    Mine seems to do the same thing. When I took it off the charger this morning, it realy 99% instead of 100. :confused:
     
  4. Etnies419 macrumors 6502

    Joined:
    Sep 9, 2008
    #4
    Mine did something similar last night (note it's a 3G, not a 3GS, but it's jailbroken with the meter enabled). I was down to about 70% when I plugged it in. It charged up to 100%, and I took it off to do something. About 20 seconds later, it dropped down to 75%. I used it for a little, and it seemed to be dropping 1% every 30 seconds... I plugged it back in, and it got up to 100%, and I haven't had any more problems.
     

Share This Page