Battery Issue

Discussion in 'MacBook Pro' started by MacMacMac8, Jul 29, 2011.

  1. MacMacMac8 macrumors newbie

    Joined:
    Jul 29, 2011
    #1
    I have a 13" unibody Macbook Pro. For some reason the fan died so I decided to replace it on my own since it was out of warranty. While replacing the fan I decided to unplug the battery as well, just as a precaution. Everything went fine (I though) but when I tried to turn it back on it wouldn't turn on until I plugged in the power adapter. Once it booted up, the battery display had a big X in it, and it said "No batteries available". I tried resetting the SMC and PRAM, but neither fixed the problem. When it was booting up from the SMC reset the battery indicator changed to "charging" for a second and then went back to the X.

    Anything I could find just said to reset the SMC and clean the battery connections, beyond that I have no idea what to do. Is my battery suddenly dead for some reason? Any ideas on what I could do?

    This is my first post, but I would really appreciate any help. Thanks to everyone on the forum.
     
  2. Darby67 macrumors 6502

    Joined:
    Jul 5, 2011
    Location:
    the corner of Fire and Brimstone
    #2
    100% guess on my part and not sure of any help. The "non-userserviceable" MBP batteries and some in recent history have a chip in them of some sort. Guessing it got upset with the disconnection somehow, other than SMC I don't have any suggestion. Bummer.
     

Share This Page