Battery issues...one phone will not charge all the way...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by VoodooDaddy, Sep 14, 2007.

  1. VoodooDaddy macrumors 65816

    Joined:
    May 14, 2003
    #1
    I know Im not the first person with this problem, but wondering if there is any known solution short of a return for a different one.

    Got an 8gb a couple days ago. Hadnt used it that much until today, because I also have a 4gb that Ive been using. The battery on the 4gb seemed pretty good to me. Would typically be over 20% by the time I went to bed. But today the 8gb, with the same average usage I was giving the 4gb, gave me the "low battery, 20%" warning at like 3pm!!

    So I come home and charge it. After about 6hrs on the charger, the plug icon is showing (has been showing since about hour 3) but you can tell there is still a percentage of the battery that is not filled.

    Compare to the 4gb, it has the plug, full battery, and the glow.

    Also, I noticed today the usage stats on the 8gb dont work, I assume because it wont take a full charge.

    Anyone found a fix, ie restoring or something?

    First pic is the 8gb that wont fully charge, 2nd the 4gb.
     

    Attached Files:

  2. brn2prgrm macrumors member

    Joined:
    Jul 3, 2004
    #2
    BUMP

    I am having this exactly same problem, anyone have a solution?
     
  3. VoodooDaddy thread starter macrumors 65816

    Joined:
    May 14, 2003
    #4
    Im hoping the next update takes care of this problem, but not holding my breath.
     
  4. drummingcraig macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #5
    Same issue here with my 8GB. I took it into the :apple: store and spoke with a "genius". He acknowledged that the usage meter obviously wasn't working/resetting properly (at the time it was reading into the "hundreds of hours" of standby, etc) and suggested that I take it home and perform a restore.

    I of course did this and it still hasn't fixed the problem. The usage meter seems to reset periodically if I let it charge up while docked to my computer, but never on the wall wort. The battery icon has never "glowed full" since I got the phone on iDay.

    The :apple: genius did make a note on my account that a problem existed and offered that if it never corrects itself I can possibly get a replacement. Not sure if I wanna go that route or not just yet...

    Craig
     
  5. carcassone macrumors newbie

    Joined:
    Sep 16, 2007
    #6
    I have similar problem with my 8GB (1.0.1). After combing thru the forums, I found that I can get a full charge if I following this procedure for charging overnight:

    - with the phone still on, connect iPhone to wall plug
    - switch to airplane mode on
    - power off

    Next morning:
    - power on (before unplugging)
    - phone is fully charged with usage reset to 0

    The key here is switching to airplane mode, which turns off both cell and wifi. If I leave the phone with airplane mode off (regular), disable wifi, and then power off, it will only get that infamous 95% charge the next morning and usage not reset.

    I know it sounds crazy since the phone is powered off so it shouldn't matter what mode it's on prior to power off but this fixed my charge problem.

    I get excellent battery usage, needing to charge only every 2 to 3 days with 12+ hrs usage, 2+ days of standby. Currently, I'm eyeballing mine at 40% left after 9 hrs of usage and 1 day 15 hrs of standby. So I am keep mine despite this glitch.

    I found my battery usage significantly improved when I only turn on wifi when I need it and checking mail manually.

    Hope this helps.
     
  6. drummingcraig macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #7
    Interesting. I will try again, but I am pretty sure that when I power the phone off and then plug it in it automatically starts up. I will try it again and report back.

    Craig
     
  7. clcnyc macrumors regular

    clcnyc

    Joined:
    Jan 6, 2004
    Location:
    NYC
    #8
    Having the same problem

    With my 8gig iPhone. Have had it since iLaunch. It seems to vary, though. Yesterday, after being charged ALL NIGHT, the battery was at the red level by 5pm, and believe me, my use is never heavy. I listen to music for 30 min on the train in the morning, and leave it in sleep/standby mode the whole day while at work. I just don't get it...I will try that trick though.
     
  8. carcassone macrumors newbie

    Joined:
    Sep 16, 2007
    #9
    You are correct that when you plug your phone in, it will automatically turns on. That's why I wrote turn on your phone first, then plug in the cable. However, I don't know if this particular step vary the result, it may work either way.

    Good luck.
     
  9. drummingcraig macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #10
    Ahhhh. I gotcha. I will give it a try!

    Craig
     
  10. PDE macrumors 68020

    Joined:
    Nov 16, 2005
    #11
    My battery situation is similar. I started a thread about getting service with an unlocked phone, but it was really about battery life so I'm going to continue here..

    I have a few issues:

    - battery life seems very low. It was charged all night and I took it off the cradle 8.30 this morning. It's now 3.30pm and I've spoken on it for 10 minutes, surfed with wifi for about 40 minutes, checked email 3-5 times. The battery gauge shows about 1/4 juice left. Bluetooth is off, wifi has probably been off half the time, autobrightness off and it's set to sleep after two minutes. No edge use at all, just those ten minutes on the phone.

    - the usage meter shows 3hrs and 53 minutes but I don't know how it estimates that since I've definitely not USED it for that long. It must calculate all time when the screen is on, regardless of activity - I guess that makes some sense. Standby time is 8hrs 15 minutes.


    We'll see how long it will actually last, but at this rate it will be dead within a few hours if I use it at all. Somebody said I should give it more time and that battery life gets better, but I'm a little doubtful at this point. I never saw the glowing /full charge icon either - there's always a thin strip left. I'm going to try turning on airplane mode and turning it off tonight to see if that helps. Hope it does. One day of usage is just too little, especially given how light usage it's seen. I don't dare get on the phone with it because it'll suck up the battery...hmm.
     
  11. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #12
    If you charge all night was the Usage at 0 when you started today. If so, it appears you used it much more then you think. If not, then maybe you are not getting a full charge. Read the other posts regarding that.

    You did not say what email you are using. Only that you only check a few times. Are you setup to do "manual" checking.

    Also, I understand Visual Voice Mail does check at an interval (not sure what interval).
     
  12. PDE macrumors 68020

    Joined:
    Nov 16, 2005
    #13
    When I checked this morning after a full night's charge, it showed usage to be 8 hours even though it obviously was not in use while I was sleeping. I turned it off and restarted and it showed zero. The problem is that I have not been using it most of the day, except the wifi surfing and a short phone call. I have played around with it a few times, but not for 4 hours. I suspect that I'm not getting a full charge and will use it until it dies and then turn it off and charge all night to see if that's better. I did do a reset this morning too just in case something was not quitting in the background...

    I have it on manual email check .
     
  13. drummingcraig macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #14
    FWIW, I have noticed that with mine, surfing via WIFI seems to drain the battery faster than anything, with surfing via EDGE being the second fastest way to drain it down.

    Craig
     
  14. PDE macrumors 68020

    Joined:
    Nov 16, 2005
    #15
    yeah, I've noticed that, but my time still seems very short. I listened to music for about an hour now with everything else off (wifi, screen, bluetooth) and now I'm on red and just got a 10% remaining warning. Usage is 5hrs 37mins and standby 10hrs 28mins - talk time still 10mins.


    Does anybody know how it calculates usage?
     
  15. carcassone macrumors newbie

    Joined:
    Sep 16, 2007
    #16
    How about:

    usage = time since power on - standby time

    Just a guess.

    If you turn on the screen but perform no action, it will still drain battery just to light up all the icons. I set mine to turn off after 1 minute of inactivity.

    Any data fetching (web surfing, google maps, etc) does seem to drain the battery faster. I use the iPod for about half a day and it doesn't seem to suck up much juice.
     
  16. PDE macrumors 68020

    Joined:
    Nov 16, 2005
    #17
    I turned on airplane mode last night, reset statistics, and then turned off the phone last night to charge it via adapter all night. When I turned it on this morning, the battery was not 'glowing' and there was still a small strip that wasn't green. The plugged in symbol was present on the top to indicate a full charge. However, despite being off all night, the usage indicator showed 7 plus hours - the time it has been charging.

    I just don't get it....
     
  17. Gibbons macrumors member

    Joined:
    Jul 17, 2007
    #18
    I had a similar issue last month. Got the little battery but not the big one. I did two restores and left the phone plugged in all night for about nine hours. When I woke up, I saw this:
    [​IMG]
    Took it to the apple store with the picture as evidence and got a replacement on the spot.
     
  18. PDE macrumors 68020

    Joined:
    Nov 16, 2005
    #19
    Did you have to make an appointment or did you just walk in and talk to one of the reps on the floor?
     
  19. Gibbons macrumors member

    Joined:
    Jul 17, 2007
    #20
    I made an appointment with a genius. But it was very fast. Explained the problem, showed the picture, and he went right back and got a brand new phone and made the swap.
     
  20. maxidious macrumors newbie

    Joined:
    Sep 21, 2007
    #21
    I have similar issue too and also i've noticed my last 20% last almost as long as the first 80% on the meter.

    Very weird.
     

Share This Page