Battery Issues??

Discussion in 'iPhone' started by esadb, Aug 14, 2009.

  1. esadb macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #1
    got my iphone about 2 weeks ago. Battery was working well and holding up good.

    But today i just noticed for some odd reason my battery is draining faster.. and im not even doing anything on the phone.. like literally NOTHING.

    I charged it over night, today at around 1PM i took it off the charger and placed it on my dresser, didnt even touch it it was in standby the entire time.. and i just looked at it 30min ago and it dropped like a junk of it (maybe 60% left???). So i played for about 5minutes the Labyrinth game and now the battery was at exactly 50%

    Which seems kind of fast to me about 3hours on standby and the battery already lost charge.. While Wednesday i didnt charge it the night before, i txted on it while at work and messed around a bit and still had a fair bit of battery left.. over 30% probably.

    And just last weekend i went from friday until sunday lunch with one battery charge and the phone was used a fair bit on txts/calls/some gaming and some light email checking.

    So i dont understand why my phone is dropping so fast today..

    I dont have a data plan and just use the phone on wifi. I have my 3G turned off. Im also wondering would that save me power by actually being off?

    I turned my wifi off, i went to town with a buddy of mine (phone was on standby the entire time) and the thing dropped down to 20%.. For no reason... this was about hour and a half after when it was at 50% before.

    I did notice tho the phone was pretty Hot in the back through my candyshell case, i also stopped by a rogers store on the way and asked. The guy apparantly had the same issue where his phone was hot and the battery dying fast and i guess he just got it exchanged by apple.

    Only thing that changed since the day before were the phone was fine was that i updated Im+

    I also just turned of "Push" under the mail settings due to the fact that i have my gmail account set under fetch for every 30min.. No need to have "Push" on correct?

    So now im wondering do i perhaps have an issue with my battery? What do you guys think? Should i just contact apple and get a replaced?
     
  2. esadb thread starter macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    Yes, it saves battery to have 3G off.

    It sounds like something is running in the background and draining your battery. I don't think you have a battery hardware issue. Since this started when you updated Im+, perhaps a setting got changed that you don't know about. Try a reset all settings (NOT an erase all content) and you can get things back to default and see how that works (your icons will be moved around and you'll have to move them back to the pages you want and you'll have to put your wifi password back in....everything else will stay intact). Your fetch settings should be an hour or manual (and supposedly it's best to have push on for mail and fetch set to manual). Try to change things back to how they were before this happened though. If you change too many things, it's hard to tell what your problem is.
     
  4. esadb thread starter macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #4
    Okay, i think im very confused here about this entire "Push" business..

    Im using gmail which does not support "Push", so technically i can just have "Push" turned off as my retrieval method? As i have my gmail account set to fetch every hour.

    Well i removed the Im+ app and i also set "Push" to off since last night. Fully charged my phone. Its been of the charger now for just over 2 hours and the battery hasnt showed any signs of drain and ive sent a few txts on it also. As well the back of it was not hot or anything either.

    So im guessing Im+ did something... or perhaps the "Push", but "Push" had been on since i got the phone so im guessing the issue was with Im+.

    Any app out there that can show you whats process is running and whats hogging the cpu/ram?
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    Yeah, I've been confused about the "push" business myself. I'm not sure I still understand it. What I can do is provide you to links from the threads where we were discussing it.

    http://forums.macrumors.com/showthread.php?t=754577&highlight=push+fetch

    http://forums.macrumors.com/showthread.php?t=762670&highlight=push+fetch

    I left the highlights on for push and fetch. As you can see, I was confused also. :)
     
  6. skye12 macrumors 65816

    skye12

    Joined:
    Nov 11, 2006
    Location:
    Austin, Tx
  7. esadb thread starter macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #7
    You read correctly.
     
  8. esadb thread starter macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #8
    Well after charging the phone last night and taking it off the charger this morning at 10AM, now its 8:40pm. It was on standby most of the time, i sent a few texts/ messed around with the calendar and i played the radio for a few minutes.

    My battery apparantly is still full.. But what i noticed was under the usage under general it has nothing listed.. I had to reboot my phone (sleep+home for 10seconds) because my fetch wasnt working or something.

    Any idea why my usage numbers are not showing now? And that my batt is still full..
     
  9. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #9
    anytime you restart you lose the usage numbers.

    are you using any battery mods? something to show your % etc etc...
     
  10. esadb thread starter macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #10
    So basically it wont show any numbers until next recharge?

    No im not this phone is not even jailbroken. But the battery did just drop a bit :)

    Just seems weird that today its lasting soo long compared to yesterday were it drained itself in about 5hours while just being in sleep... And today I even left fetch on at 15min.
     
  11. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #11
    have you drained it done dead and give it a nice long charge?
     
  12. esadb thread starter macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #12
    Well yah yesterday i mean the phone was nearly dead because i was out with some friends so when i came home i was able to charge it. Like i said it drained itself pretty much within 5-6hours while standby/lock screen. So when i came home id say the battery was down to prob 10-15% cause i did get the 20% message a bit earlier that night
     

Share This Page