battery listed as "finishing charge..." since upgrade?

Discussion in 'MacBook Pro' started by xhopex, Feb 11, 2008.

  1. xhopex macrumors newbie

    Joined:
    Feb 11, 2008
    #1
    hi, i upgraded to 10.5.2 this afternoon & since then my battery has shown as "finishing charge..." which i have never seen before. i unplugged it for a little bit then plugged it back in, once it got back to 100% it still shows this message. according to istat it's 100% charged...is anyone else having this problem? i am on a 2.16 blackbook.

    [​IMG]
     
  2. chevitron macrumors newbie

    Joined:
    Apr 29, 2007
    #2
    Same here after the upgrade. The light won't turn green, despite iStat indicates 100% (OSX stays on 99%).

    MBwhite 2.2 2GB
     
  3. jeff3221 macrumors regular

    Joined:
    Nov 14, 2007
  4. chrisbeebops macrumors regular

    Joined:
    Jun 8, 2007
    #4
    Try calibrating the battery and see if that helps.
     
  5. The Flashing Fi macrumors 6502a

    Joined:
    Sep 23, 2007
    #5
    Happens to me, but it only lasts a few minutes. It's just topping off the charge and making you aware that it's almost finished.
     
  6. daveman1024 macrumors newbie

    Joined:
    Feb 15, 2008
    #6
    I have exactly the same problem. It says "FInishing charge" while istat indicates my battery is 100% charged. The charge indicator on powerplug indicates "red" and does not turn to "green" anymore.

    Chargetime increased as well: It always took approx 2 hrs to fully charge the battery, now it takes 2 hrs, 45 min to charge until the above indicated state.....

    Problem started since upgrading to 10.5.2.

    I already tried resetting the pmu and tried to upgrade the battery.

    My Macbook was shipped on jan 4 to me (so, brand new!)

    Called mac helpdesk and problem is not (yet) known to them.
     
  7. neda macrumors member

    Joined:
    Nov 4, 2005
    #7
    my powerbook is doing the same except it wont charge the battery, its stuck at 95%, but the plug is green!
    It was fine before upgrading to 10.5.2
     
  8. spookybathtub macrumors newbie

    Joined:
    Feb 15, 2008
    #8
    I have also seen this message since upgrading to 10.5.2 on my Powerbook G4. It seems to correspond to iStat Pro, however. It says "Finishing Charge" for less than 10 minutes, and then says "Charged".

    It doesn't seem to have any problems for me. It's minor, but I like this message better than the old "Calculating".
     
  9. Solowalker macrumors regular

    Joined:
    Feb 13, 2008
    #9
    I had this same problem today, but I had just assumed it was because it was the first time I had calibrated my battery (a year and a half old MacBook). Since 10.5.2 my charge time to 100% has drastically decreased, but it took at least an extra hour today to "finish" charging after calibration. Glad I'm not the only one.
     
  10. AppYosef macrumors newbie

    Joined:
    Feb 29, 2008
    #10
    Same problem

    Listed as finishing charge for upwards of 30 minutes and takes a lot longer to get there too.
     
  11. CisternaChyli macrumors member

    Joined:
    Mar 1, 2008
    #11
    im having the same problem as well..just upgraded to 10.5.2 today...what gives!
     
  12. bhsu21 macrumors 6502

    Joined:
    Feb 25, 2008
    Location:
    Jacksonville, FL
    #12
    I just noticed this today as well. Stuck at 95%. I wish there was an answer why. It was fine before the upgrade as well for me.
     
  13. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #13
    If the charge drops below 95% it will begin charging. The reason why it doesnt is because when it reaches 100% it then begins to trickle charge. Eventually it will run slowly down to 95 to begin the cycle again. It's normal.

    To the OP, try calibrating or discharging beyond 95%. Charge it and see what happens. How long do you wait for the message to change to Charged? It doesnt happen instantly.
     
  14. ag227 macrumors regular

    Joined:
    Jun 11, 2007
    #14
    my brand new blackbook did this to, what concerned me more was that the magsafe light never went green.. making me believe it was still charging and not wanting to leave the macbook incase it over charges. i rang apple and they sent me a brand new blackbook which doesnt do this which is quite odd!
     

Share This Page