Battery % not accurate in iOS7

Discussion in 'iOS 7' started by SteveJobs2.0, Sep 27, 2013.

  1. SteveJobs2.0 macrumors 6502a

    Mar 9, 2012
    I found that the battery percent worked perfect in iOS6. However, it seems to be very wonky now. I have had the phone shut down ahile showing 3% battery left. I once had it drop from 20% to 13% in a minute or two... only to go back up to 18% after. Is anybody else experiencing this?
  2. dcp10 macrumors 6502

    Jul 30, 2010
    Yep, since the betas. I think my battery life might be fantastic, but I can't get a good read because of this. Hoping the next update addresses this issue.
  3. Zerilos macrumors 6502a

    Dec 18, 2012
    I have the opposite issue. I normally get about 20 more minutes of use (not standby but actually using the phone) when I hit 1%. Never had it shut down early. Not sure why the experiences are so varied.
  4. stevod macrumors member

    Jan 25, 2009
    Are you having the problems in 7.0 or 7.0.2?

  5. Bulldog28 macrumors newbie

    Nov 10, 2011
    I had this problem too. Incorrect battery % and my battery seemed to drain faster. At one point it was fully charged and with on 3 hours of use it was down to 10% and then it shut down. So I was looking through the forums and some of them said to to restart the phone. Backup. Erase all content and settings and let it reboot and then restore from the previous back up. It worked for me. My battery than went back to being normal the way I'm used to using my phone. So for those having battery issues, trying restoring your phone. Maybe it will work, maybe it won't but I'm just telling my experience.

    Attached Files:

  6. TonyC28 macrumors 65816


    Aug 15, 2009
    This happens for me too. Seems like that last 1% is a reallllllly strong 1%.
  7. Will2145 macrumors 6502


    Nov 8, 2012
    Vancouver, Canada
    Wow happened to me right now... Was at 20% and jumped to 10 in less than a minute. I also had problems when my phone shuts off at 20% and down

Share This Page