Battery not charging when MBP is on!?

Discussion in 'MacBook Pro' started by frshhh, Aug 14, 2007.

  1. frshhh macrumors newbie

    Joined:
    Apr 1, 2007
    #1
    Only had my MBP for 2 months - heres my first problem. :(

    Like it says, it doesn't charge when its turned on... the LED on the magsafe connector flashes green/off (not green/amber btw)... also, the screen turns off quickly... as if no power was connected and it's conserving power.

    If i turn it off, the magsafe LED goes amber and it charges ok... turn it back on... LED flashes w/ no charging.

    I cant find any info from apple about what the green/off flashing means.

    This is V.annoying and V.crap!... Any ideas?
     
  2. frshhh thread starter macrumors newbie

    Joined:
    Apr 1, 2007
  3. Magick macrumors member

    Joined:
    Aug 9, 2007
    Location:
    Delft, The Netherlands
    #3
    is the magsafe connector clean? (no dirt/dust)
     
  4. klymr macrumors 65816

    Joined:
    May 16, 2007
    Location:
    Utah
  5. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #5
    Sounds like a dodgy magsafe charger - take it back to Apple or if there isn't a store around, give them a call.
     
  6. frshhh thread starter macrumors newbie

    Joined:
    Apr 1, 2007
    #6
    Thanks guys for the replies.

    Just a quick update in case anyone else has the same problem and finds this thread.

    A few hours after starting this thread, my MBP now wont turn on... at least the screen and lights dont turn on but you can hear the HD and CD drive spin up.
    I phoned applecare (used up all of my skype credit waiting on hold! :mad:) who told me to take it to my local service centre.

    Being a not so wealthy student, and my MBP being an expensive £2000 investment for me... im not too impressed, especially as ive only had it for 2 months!

    Im starting to wish more than ever that Logic Pro was available for PCs :(.... although i still love my silver slab of sexiness.
     

Share This Page