Battery of iBook G4 not charging

Discussion in 'Macintosh Computers' started by delmar78, Aug 3, 2005.

  1. delmar78 macrumors newbie

    Aug 3, 2005
    Recently, the battery of my iBook G4 (OS 10.4.2) stopped charging. The light on the power cord does not change to orange, but remains green. With the power cord plugged in, the battery fortunately does not drain.
    I tried several things: I did reset the PMU (power management unit) with no result. I swapped the power cord and battery with a colleague's, also with no result. In his iBook, my battery and power cord worked fine (ie charged), but in my iBook his battery and power cord would not charge. It will also still run when I remove the battery.
    In the system profiler, my battery seemed to be fine: maximum capacity was 4144mAh (of a max of 4400 when the battery is new).
    However, in the system profiler, a few lines below the one about the battery capacity, system profiler has a strange line (I translate this from dutch):
    "Power adaptor can not charge battery: yes"
    If I could change this "yes" into a "no", it seems that my problem would be solved. Does anybody have a clue how to solve this problem?

    I have the impression that this problem could be solved by changing a setting in the terminal. I used a terminal application called battery, which returned the following result:
    "Charger: charger connected, not charging, no charging capability"
    Unfortunately, that application cannot change any settings. I do not speak enough "terminese" to change this. Please help!
  2. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    How did you reset the PMU / non-volatile RAM exactly? There are several different techniques (Cmd-opt-P-R on reboot, the series of open firmware commands, etc), which don't seem to be completely equivalent... You might try the ones you haven't tried yet. I'm not exactly sure how they're different, but they seem to be.

Share This Page