Battery Problem

Discussion in 'iPhone' started by Redneck1089, Sep 3, 2009.

  1. Redneck1089 macrumors 65816


    Jan 18, 2004
    My iPhone 3GS has been getting exceptional battery life until last night. Normally I'd get anywhere from 5-7 hours of hard usage out of it. I have Push off, Location Services off, 3G on, wifi off and on (depending on whether I have a connection available), and brightness about 40%.

    After unplugging my phone from the wall last night I noticed that the battery dropped about 10% in a matter of a few minutes. I ended up getting an hour and a quarter out of that charge. This morning I decided to do a restore. Still, got terrible battery life afterwards. I did another restore, this time setting the phone up as a "new phone." At first I started getting my familiar battery life and then all of a sudden the battery percentage indicator dropped 10% right before my eyes. After a few more minutes of usage it went back up 10%, and then dropped 10% again! Since that charge I've used the phone for 2 hours and 50 minutes. I was getting 5-7 hours before! I let the phone completely discharge and I'm doing a complete charge cycle now.

    Do you think my battery has suddenly gone bad? This is such a pain in the ass - I'm leaving for September Long Weekend and need my phone!
  2. Kaushal macrumors member

    Sep 26, 2008
    Calibrate the battery a few times.

    I did it 2 times & my phone gives me exceptional battery life now.

    If it still does not give u good battery life, then go to apple for replacement:apple:
  3. DotCom2 macrumors 68040

    Feb 22, 2009
    Yeah, I calibrated my new 3Gs's battery 3 times and got a much improvement after that.
    If you did indeed do a restore to backup, and then a restore to new, and then a good calibration, if you still have bad battery usage, take it's bad.
  4. Redneck1089 thread starter macrumors 65816


    Jan 18, 2004
    So far I'm getting better battery life after recalibrating it for the third time. The battery indicator already has jumped around a bit though, going down to 94% with 20 minutes of usage. All of a sudden it jumped back to 97%. Since then it's been consistently dropping one percentage at a time. Still seems to be dropping a little fast for what I'm using the phone for. I think I might call Apple.
  5. DotCom2 macrumors 68040

    Feb 22, 2009
    Give it some time.
    I got mine about a week and a half ago and it's been getting progressively better.
  6. jason221 macrumors 6502

    Jun 26, 2009
    My battery (3GS) went to about 80% from 100% last night after watching a 1.5 - 2 hr movie on half brightness, push, fetch, and location off. That's not that bad. However, it seems Internet services drain the battery a lot faster. What I can't get over, though, is that the percentage indicator on my 3GS is almost always 3% higher than the percentage on the Free Memory app. I've tested this with multiple battery percentage apps, and they all read the same percentage (3 percent lower, generally). Occasionally the Apple percentage will be 2% higher, or sometimes even equal when plugging the phone in to charge, but they never stay equal all the time. I've tried "Reset All Settings" but I haven't tried a full restore yet and setting up as new phone. One reason is that I'm jailbroken, and another is because it's a hassle setting up a new phone. This issue existed on 3.0 for me and still does on 3.0.1.

    Edit: I've tried calibrating the battery once or twice as well.
  7. jimf123 macrumors member

    Jun 9, 2008
    I'm glad I've seen your thread. For the last 2-3 days my few month old 3gs and my wifes 2g iPhone have been going very very strange. Both phones are having really bad battery life, down to the same hour or our and a half before they die. But the percentage meter is going mad - dropping like a stone literky in front of your eyes, but then seeming going back up by 10 or 20 percent.

    I don't claim to have had fantastic batterylife on either phone in the past, but I did manage between 4 & 5 hours on my 3gs and maybe 3-4 on the 2g.

    Something weird has happenned. We are running 3.01 in the uk on both phones now, and both had a carrier update fairly recently. I'm starting to take some screenshots ready to take my 3gs in to the apple store, but obviously the 2g is now out of warranty. I'm not at all sure it's the phones though, it strikes me as a code or other problem in that they both started acting the same in the last couple of days.

    Anyone else seeing this in the UK?
  8. Redneck1089 thread starter macrumors 65816


    Jan 18, 2004
    I called Apple today and they're going to send me a brand new iPhone. They wanted to send me another refurbished unit but I said that I've had several refurbished iPhone 3G's in the past and that each one I've had the quality has been worse than the last. The representative eventually caved and I got my way, but it took over an hour on the phone to do.

Share This Page