Battery Problems - Will not recharge

Discussion in 'MacBook Pro' started by nickarmadillo, Jan 7, 2009.

  1. nickarmadillo macrumors regular

    Joined:
    Jan 24, 2003
    Location:
    St. Louis, MO
    #1
    17" 2.33 Core 2 Duo from 2006

    The computer only works when the magsafe is plugged in. There is an orange LED on the magsafe connector, but battery does not seem to charge. No LEDs light up on the battery indicator and the menu bar indicates that there is a 0% charge and that recharge time is 10:00. However, these numbers do not change. Get the lightning bolt icon, so it looks as if it should be charging. What could be wrong?
     
  2. nickarmadillo thread starter macrumors regular

    Joined:
    Jan 24, 2003
    Location:
    St. Louis, MO
    #2
    Now it seems to be recharging. I had to leave it in for about an hour and all of a sudden out of nowhere the battery began to recharge. Not sure how that happened, but any ideas?
     
  3. kornyboy macrumors 68000

    Joined:
    Sep 27, 2004
    Location:
    Knoxville, TN (USA)
    #3
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    It looks like a bad battery. You'll have to get a new one. The battery is a couple of years old and that's about all you can get out of one. You can try checking the cycles in system profiler and if it is over 300 then the battery is probably shot.

    Hope this helps.
     

Share This Page