Battery problems

Discussion in 'Mac Basics and Help' started by Pfusion, Oct 17, 2007.

  1. Pfusion macrumors newbie

    Joined:
    Oct 16, 2007
    #1
    I have had a sudden change in my battery charging ability. It worked fine on a recent trip and when I returned I left it on my desktop uncharged for a couple of days, then plugged it in. This morning I tried to use it and the computer died when I unplugged it. My battery won't charge! I press the battery fuel button on the battery and nothing. No lights, nothing!! I've removed the battery, cleaned the contacts and reinstalled without success. The adapter light goes to amber for about five minutes then to green all the while the percentage (of battery life) stays at 0%. Even when I remove the battery the charge light still stays green. I've tried zapping the PRAM and resetting the PMU (mac 10.3.9 - 15" powerbook G4 FW800) again without success. Do I need to get a new battery? Thanks for any suggestions.
     
  2. seeker777 macrumors member

    seeker777

    Joined:
    Oct 15, 2007
  3. lamina macrumors 68000

    lamina

    Joined:
    Mar 9, 2006
    Location:
    Niagara
    #3
    Hold down the power button until you hear a loud (BOOOOOOOOOOOOOOOP), and you will notice the light on the front of the computer flashing.

    That will reset the power management unit, or whatever they call them on the MBPs.

    Let us know if that works.
     

Share This Page