Battery showing not connected then charged???

Discussion in 'MacBook' started by King Luis, Oct 26, 2008.

  1. King Luis macrumors 6502

    Joined:
    Jul 3, 2008
    #1
    so just recently my first problem has occured with my macbook.

    with the battery fully charged and the power connected, my macbook goes from showing the battery charged to a battery icon with a X in it as not connected in black.
    i got about 110 cycles on the battery. the indicators on the battery show fully charged.

    any ideas? i got a trip in 2 weeks where i'll need my laptop to transfer pictures.
     
  2. King Luis thread starter macrumors 6502

    Joined:
    Jul 3, 2008
    #2
    bump....i tried the SMC reset and the battery seemed fine last night but this morning, it's powered off. now i don't know if the battery just ran out or if it cut out and showed disconnected.
     
  3. NC MacGuy macrumors 603

    NC MacGuy

    Joined:
    Feb 9, 2005
    Location:
    The good side of the grass.
    #3
    I've had MB's with these symptoms and it's been either bad battery - not real bad - or bad logic board - SUPER bad.
     
  4. King Luis thread starter macrumors 6502

    Joined:
    Jul 3, 2008
    #4
    craptastic. i hope its just the battery. my protection plan is up in february....maybe i can go today and get it looked at.
     
  5. Skeletal-dæmon macrumors 6502

    Joined:
    Apr 27, 2008
    #5
    Oh dear. Dad's iBook did this and unfortunately for him it was the logic board.

    I hope that its just your battery mate, good luck getting it checked!
     
  6. NC MacGuy macrumors 603

    NC MacGuy

    Joined:
    Feb 9, 2005
    Location:
    The good side of the grass.
    #6
    Protection plan on just the battery?
     
  7. eman macrumors 6502a

    Joined:
    Nov 5, 2007
    Location:
    In the great white north
    #7
    Do you have the battery software update from Apple.
    Can you swap out your macbook battery with another macbook battery from a friend etc.. to test if the battery is the problem. The battery connector could also be bad.
     
  8. King Luis thread starter macrumors 6502

    Joined:
    Jul 3, 2008
    #8
    isn't the battery covered under the whole laptop?

    no other battery i can test with.
    i completely drained the battery last night and charging it now.
    lets hope it gets fixed by a good cycle.
     
  9. King Luis thread starter macrumors 6502

    Joined:
    Jul 3, 2008
    #9
    so after completely draining the battery then doing a full recharge, it seems to be working fine now.

    Charge Information:
    Charge remaining (mAh): 4688
    Fully charged: Yes
    Charging: No
    Full charge capacity (mAh): 4703
    Health Information:
    Cycle count: 109
    Condition: Good
    Battery Installed: Yes
    Amperage (mA): -1607
    Voltage (mV): 12316

    thanks for the help guys.
     

Share This Page