Battery slowly loses charge while plugged in

Discussion in 'MacBook Pro' started by tigress666, Sep 2, 2010.

  1. tigress666 macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #1
    Ok, just curious, does anyone else's MBP's battery slowly lose charge over time even though it's plugged in? I've got a 2010 MBP 13".

    Mine only is ever at 100% right after I have used the battery and just recharged it. then it will slowly lose that charge over time until I unplug it, use the battery enough for it to actually charge the battery when I plug it in.

    (Oh, and coconut battery has never said it ever had 100% full original battery capacity, best it ever said was 97%).
     
  2. Bankaimadness macrumors 6502

    Joined:
    Jun 7, 2010
    #2

    Download Istat and look at how many recharge cycles you have.
    This should give you some insight to your problem.
     
  3. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #3
    Says just 10. I mean it is just a few months old.
     
  4. Timur macrumors 6502a

    Timur

    Joined:
    Oct 14, 2008
    #4
    The battery loses charge by itself, it's normal. The battery is only loaded when it falls below ~95%. High CPU and GPU load draws from the battery even when plugged in.
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
  6. greythorne macrumors regular

    Joined:
    Mar 10, 2008
    #6
    Yup mine does that too.

    When its fully charged i will just leave it plugged in for atleast 2days then probably on the first day i can see the battery drops to 99% then later on will drop to 98% this is where i will unplug and start from the battery and when the battery drops to lets say 25% i will charge it and the cycle continues for me.
     

Share This Page