battery status "Not Charging"

Discussion in 'Mac Basics and Help' started by fakhir, Nov 9, 2009.

  1. fakhir macrumors newbie

    Joined:
    Feb 3, 2008
    #1
    Dear All,

    I have two years old Macbook 10.
    Since last two weeks my battery status showing not charging. Adapter light is very dim green. battery condition is good and i have enough cycles to use. charger is working fine with other macbooks.

    I have done SMC as suggested by someone... but no result :(

    Please help and also where i should take it for service in delhi and how much it will cost as it is not in warranty anymore.

    Thanks in advance
     
  2. neutrino23 macrumors 65816

    Joined:
    Feb 14, 2003
    Location:
    SF Bay area
    #2
    I'm suspicious that the problem is the battery. Two years for a battery is within the reasonable time where it might fail. Bad batteries can have very odd behavior which is hard to understand.

    If the charger is working OK on other Macbooks it would seem that we can rule out the charger as a problem.

    Can you borrow a battery to test in your computer? See if the charger behaves normally on your machine with a good battery. Or try the battery in another machine.

    I've seen two batteries fail, one at about a year and the other at a little over two years old. Several other laptop batteries I've had showed their age by holding less and less charge as time went by.
     
  3. fakhir thread starter macrumors newbie

    Joined:
    Feb 3, 2008
    #3
    thanx for quick reply.

    but in the system profile battery condition shows good.

    also how much a battery replacement will cost me in new delhi india?
     
  4. fakhir thread starter macrumors newbie

    Joined:
    Feb 3, 2008
    #4
    one more thing...

    my battery is more than 60% charged and my mac runs perfectly on battery if i remove the adapter. and i dont think a dead battery will run the machine. it its dead it would have shut off when removing the charger.
    what u think
     
  5. kroeks macrumors regular

    #5
    i sometimes have this issue too with my macbook.
    I know this is going to sound wierd, but try and plug out the adapter, turn the plug 180' around and put it in again.

    It works for me almost every time.
    Dunno why, maybe there's something broken in the plug
     

Share This Page