Battery themes not working

Discussion in 'Jailbreaks and iOS Hacks' started by Dandrews524, Feb 20, 2011.

  1. Dandrews524 macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    New York
    #1
    i downloaded a couple different battery themes from cydia and for some reason they arent working. is there something special you have to do to get them to work or are they just crappy? i tried turning each one on in the theme section of winterboard but it wont work. any suggestions?
     
  2. Dandrews524 thread starter macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    New York
  3. WhatAmI macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #3
    are you 100% positive the theme you're downloading is compatible w/ your fw version? This is the most common reason...
     
  4. h1r0ll3r macrumors 68040

    h1r0ll3r

    Joined:
    Dec 28, 2009
    Location:
    Maryland
    #4
    By Battery theme do you mean the battery icon in the status bar or the battery icon on your lockscreen whenever you charge the phone?
     
  5. Tokes Green macrumors regular

    Tokes Green

    Joined:
    Jan 25, 2011
    Location:
    Here, there, and everywhere.
    #5
    Put it at the top of the Winterboard list maybe?
     
  6. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #6
    lets just say your not providing much info if you want help. maybe the firmware version and the theme or themes for starters! ;) personally I've played with a few but don't really find it necessary mod anymore.
     
  7. Dandrews524 thread starter macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    New York
    #7
    well im running 4.2.6 and i just recently used greenpois0n to jailbreak my phone for the first time. i am new to jailbreaking but i find it highly useful and cant understand why i was too afraid to do it for so long. i was just flippin threw some themes on cydia and found some really cool ones that were very easy to apply. then i found a "burning joint" battery theme that changes my batter into a joint when its charging. im aware of how stupid that sounds, trust me. anyhow i couldnt get it to work using winterboard, so im guessing it must not be compatible with 4.2.6. thanks for the tips anyway guys
     
  8. acidiica macrumors newbie

    Joined:
    Feb 21, 2011
    #8
    I found that mine would do the same thing when I tried to change the color of my battery charging icon as well. I'm new like you and only got my phone finally jailbroken two or three days ago and I think I'm using the same version of greenpoison.

    I was wondering if the fact that mine is a verizon iPhone matters... but I figure it wouldn't since the only thing I believe that is different is the iOS version (4.2.6 I think?). I'm not positive on this though at all (being a n00b iPhone user of only a couple weeks thus far).:p
     
  9. Dandrews524 thread starter macrumors 6502

    Joined:
    Jan 30, 2009
    Location:
    New York
    #9
    i am a verizon iphone user also using 4.2.6
     
  10. Xhita macrumors member

    Joined:
    Nov 2, 2010
    Location:
    Switzerland
    #10
    There's a lot of things that can interfere with a battery theme, specially after 4.2.1
    For example, for my lockscreen I'm using AnalockHD and that's all that shows when the phone is charging. I've tried a couple of battery themes (without having AnalockHD on) and one that worked for me perfectly was 3D Gauge HDready.
    I'm afraid that with 4.2.1 it's a question of error and trial, at least until most themes are updated to the latest iOS...
     
  11. sodeelish macrumors newbie

    Joined:
    May 4, 2011
    #11
    It's due to the difference in retina screen on the iphone4. these battery themes were meant for 3g/3gs. you can SSH into the file and at "@2x" before the .png and it will change the color, but since that changes the size of the image, the battery will be small. here's what it looks like with modified image names:

    [​IMG]
     
  12. prplhaze macrumors newbie

    Joined:
    Jul 14, 2010
    #12
    Basic mods / themes not working?

    Hey having the same problem, but not only with the batteries....

    As I mentioned in this thread about the lockscreen sliders
    http://forums.macrumors.com/showthread.php?t=1140056

    I am also having problems with the charge-battery themes not working.

    I have at AT&T iPhone 4 with 4.3.2 recently jailbroken for the first time using QuickPwn if I recall correctly (the one with the pineapple)

    I have tried to enable and re-rank all my winterboard themes, but no sliders or battery themes I've tried work.

    Some I've tried are
    Lockscreen sliders: Obey, volcamslider, GlassSliders, Apple (color) sliders
    Battery themes: Helix Battery, HAL Battery

    And, while I'm at it, the dialer theme didnt working either. I tried Retro Dialer.

    What gives?!
     
  13. praze macrumors newbie

    Joined:
    Feb 20, 2012
    #13
    I know this is a dead thread, but the problem still persists (even with very popular themes) and I've found a more complete workaround...

    Instead of just changing the file names to "@2x.png", if you also go in and scale the image up to 200% (using any image editing software) it will line up correctly and work as the theme intended.

    So, the re-hash the whole process...

    1: Using SSH, access the iPhone's root file structure.
    2: Navigate to the directory for the image files you want to change.
    *Slider - "/Library/Themes/[theme name].theme/Bundles/com.apple.TelephonyUI"
    *Battery - ""/Library/Themes/[theme name].theme/Bundles/com.apple.springboard"
    3: Add "@2x" to the end of every png file name before the ".png" extension (eg. "bottombarbkgndlock@2x.png")
    4: Download all the renamed png files in the folder to your computer.
    5: Using any image editor (photoshop, office photo manager, paint), scale the image up to 200% (both height and width, eg. 264x129 pixels becomes 528x258 pixels)
    6: Transfer the altered png files back onto the iPhone, overwriting the original renamed files.
    7: Ensure the theme is active in WinterBoard and respring or restart your iPhone.

    I got this working in iOS 5.0.1 (redsn0w jailbreak)

    I there's anything else that seems small or is not displaying correctly, what I did is download the whole .theme folder to my computer and searched for all png images within it. In a thumbnail view you should be able to find the file(s) that affect it and resize them accordingly. When done, you can just overwrite the whole .theme folder on the phone instead of overwriting the individual files one-by-one. Many files don't seem to require the "@2x" suffix, but you'll need to experiment if you're not getting the results you want. Good luck!
     

Share This Page