Battlefield 1942 update problems

Discussion in 'Mac and PC Games' started by bigred8888, Nov 2, 2008.

  1. bigred8888 macrumors newbie

    Joined:
    Nov 2, 2008
    #1
    I have Battlefield 1942 deluxe edition. I have Macbook with Mac OSX leopard.
    I have tried to update to the 1.61D patch but when i begin updating it gets stuck at the very beginning. Any suggestions? Thanks.
     
  2. Airborne50 macrumors newbie

    Joined:
    Nov 9, 2008
    #2
    You're not alone

    I am having the exact same problem, I have tried uninstalling and reinstalling, didn't work. And I am about to give up hope any help greatly appreciated. (Maybe someone should try emailing the 1.61d patch folder to us that might work)
     
  3. bfos10 macrumors newbie

    Joined:
    Dec 16, 2008
  4. bfos10 macrumors newbie

    Joined:
    Dec 16, 2008
    #4
    The delux edition is fully updated when you intsall it. version 1.6. go to cusotm game, when running, and you will see that your version is up to date.
     
  5. Trexchard macrumors newbie

    Joined:
    Dec 31, 2008
    #5
  6. FletchRDG macrumors newbie

    Joined:
    Jan 31, 2009
    #6
    right Ive got the update 1.6 1D but the instructions arent very clear as to where to put it and what should do, I alo have a problem installing BF1942: secret weapon. have more then the requirments and i have BF 1942 deluxe edition but it stops at the beginning. can anyone shed light on the problem?
     

Share This Page