Beach Ball after Resetting Safari in Mavericks 10.9.2

Discussion in 'OS X Mavericks (10.9)' started by punchwalk, Feb 28, 2014.

  1. punchwalk macrumors regular

    Joined:
    May 16, 2010
    Location:
    Maryland, USA
    #1
    Hi all. I'm posting this in the OS X Mavericks forum because this problem did not start occurring until after I upgraded OS X from 10.9.1 to 10.9.2 a couple of nights ago.

    I'm one of those overly-cautious folks who resets Safari at least once or twice a day. Since upgrading to 10.9.2, resetting Safari (with all options checked) causes Safari to hang/beach ball indefinitely about 20% of the time. A force quit resolves the issue, but it's a little annoying. Has anyone else experienced this?
     
  2. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #2
    I used to see the beach ball for a few nanoseconds here and there in Safari under 10.91. Oddly haven't seen the cute little spinner at all since 10.92.
     
  3. anp27 macrumors regular

    Joined:
    Jan 17, 2011
    Location:
    Brooklyn, NY
    #3
    Just installed 10.9.2 and no sign of beach balls.... fingers crossed! My wifi works just fine too.
     
  4. martosprint macrumors 6502

    Joined:
    Jun 1, 2010
    Location:
    Florida
    #4
    I installed the update 10.9.2 when it first came out and it seemed to have solved the beach balling which I had prior to 10.9.2 and haven't seen the beach ball since. That update has solved the problem.
     
  5. ishark macrumors newbie

    Joined:
    Mar 3, 2008
  6. Silver Smith macrumors newbie

    Joined:
    Mar 14, 2014
    #6

    Hi
    I've have the same issue since 10.9.2. Trying to sort via the Apple forum. I've a Macbook late 2008 and all reset options ticked except the notification warnings one. No extensions. Only, iPhoto, QT and flash plugins. The longer I have safari open before resetting the more likely it's occurring.

    Have you had any success in resolving? If so how?

    SM:confused:
     
  7. thirdeyeopen666 macrumors 6502

    thirdeyeopen666

    Joined:
    Sep 16, 2007
    #7
    Sounds like it could be corrupted bookmarks. I'd export your bookmarks, delete them manually in Finder and then re-import them.
     
  8. punchwalk thread starter macrumors regular

    Joined:
    May 16, 2010
    Location:
    Maryland, USA
    #8
    For anyone who finds this thread: The issue appears to have been resolved by OS X 10.9.3, Safari 7.0.4, or a combination of the two.
     

Share This Page