beachball issue with iMac i7 and SnowLeopard

Discussion in 'iMac' started by Seraph301083, Dec 22, 2009.

  1. Seraph301083 macrumors member

    Joined:
    Nov 8, 2009
    #1
    Hello!

    When I received my new iMac I was really impressed and relieved because it was flawless. After using it for 4 weeks there are some issues.

    One minute everything works fine and suddenly, without any reason I get the spinning beach ball for like a minute, everything frozen, after that it goes back to normal and everything works fine again.

    My first suspect was Firefox because it happens a lot when I'm surfing the web or watching youtube movies, but it also happened when I switched to Safari, Chrome,... so it's not only firefox related.

    My second suspect was the HD. So I checked it. First with Disk Utility, then with Apple Hardware Test, SmartReporter and finally with TechTool Pro. No Issues found. No HD Issue and also no RAM issue. I checked the RAM too because I added 2x2GB.

    So now I believe (or lets say I hope) it is Snow Leopard.
    Could it be because I was so excited about my new iMac so I just started using it instead of making a clean install??

    Do you think it will be resolved by formatting everything and making a clean install? I'm also thinking about switching back to Leopard but I'm not sure.. is it even possible to install leo on these new iMacs? will the performance suffer from it because of the 64bit?
    please let me know what you guys think..
     
  2. BelowTheBelt macrumors regular

    Joined:
    Aug 16, 2009
    #2

    When I received my iMac i7 I formatted & zeroed the drive right out of the box.

    I would back everything up and do just the same on yours.

    Will this fix the problem, who knows; however there is a good chance it will resolve the issue for you mate. I would steer clear of Leopard as there will be no driver support on the older OS X Disc.

    Funny you mention FireFox because it takes about 30 seconds to launch on my machine, Safari is amazingly fast. I suffer no beach ball's tho.

    Mine has been trouble free and simply a pleasure to use.
     
  3. Yakuza macrumors 6502a

    Yakuza

    Joined:
    Jul 24, 2007
    Location:
    Lisbon, Portugal
    #3
    I'm not an expert-guru-all mighty know it all lol, but with all that testing and everything is ok, do it, do a clean install, i read that this issue affected others and they did a clean install. don't know what happend next.

    but surelly others will tell you the way to follow, but i would bet on a clean install.

    Had some issues sometime ago, on a MBP, and a clean install did the trick. did you made the permission repair? i think it call's this way lol, i'm not at home.
     
  4. Seraph301083 thread starter macrumors member

    Joined:
    Nov 8, 2009
    #4
    well thanks for your answers!

    yes I did a disk permission repair.

    I think I'll go with the format/reinstall SL (I would really want to try Leopard but as you said.. this is a new machine and never meant to have Leo installed).. I'm not happy about it because my system is set up pretty good now despite this freezes

    hopefully this will resolve my problems

    I'll keep you posted
     
  5. Serif macrumors regular

    Joined:
    Jul 10, 2008
    Location:
    UK
    #5
    I'd be very interested in whether your clean reinstall fixes this. It's puzzling that a hyperthreaded quad core system can be locked up as you describe. It sounds like the Finder is being tied up waiting for something to complete or time out. It also implies that this wait/timeout is being handled by a single thread which again is surprising.
     
  6. BelowTheBelt macrumors regular

    Joined:
    Aug 16, 2009
    #6
    Mate, I would take special care to make sure you zero the drive as well.
    When you do this it picks up all of the bad blocks and takes note of them, the system will then never try to write data to these places.

    You might have had a bad block that some piece of OS X was written to and the system was hanging while trying to retrieve the information written there.

    It takes a long long time, but in my opinion it's worth the wait buddy.
     
  7. DarwinOSX macrumors 65816

    Joined:
    Nov 3, 2009
    #7
    Run Diskwarrior. Also fix permissions. Use Onyx to delete caches etc. Reset the PRAM. If none of that works then erase the drive and a clean install.
     
  8. DarwinOSX macrumors 65816

    Joined:
    Nov 3, 2009
    #8
    That is not what zeroing the drive does. It only make data much harder to recover once you delete. It is unlikely in this day and age that you will have bad blocks on a new drive. If you do a standard reformat and disk initialization you will not use bad blocks anyway.

    http://support.apple.com/kb/HT1820
     
  9. thiagos macrumors 6502

    thiagos

    Joined:
    Dec 20, 2007
    Location:
    NYC (Manhattan)
    #9
    From someone who has been through this I can honestly tell you that you have a hard drive that might have become defective. That happened to me with a Seagate hard drive (make sure it is not Seagate if it is ask Apple to swap it to a Western Digital drive). I would get long 10 second beachball pauses, long application launch times. When I tried to transfer large files I would get errors, etc etc. When running disk utility, it seemed that everything was fine, ran a hardware test, no errors either. I had done a complete system restore, 7-zero pass erase and fresh installing Snow Leopard, nothing fixed it. Once I swapped the hard drive and it worked like a charm.

    I would honestly advise you to swap that hard drive, it is only gonna get worse... My 2 cents...
     

Share This Page