Beginning to regret purchasing my Mac Mini?

Discussion in 'Mac Basics and Help' started by sir Mudkip, Aug 29, 2008.

  1. sir Mudkip macrumors member

    sir Mudkip

    Joined:
    Aug 25, 2008
    Location:
    Adelaide, Australia
    #1
    Honestly.
    This thing is pissing me off. I have two perfectly good working WD external harddrives (my book world edition& Passport 120gb) that merrily were used on my pc, but whadya know! No spinning sounds, no disk utility recognition or anything!

    This thing also wont sync my better camera, and also my phone (which apparently can sync with macs >,>). It takes forever to be restarted, and configuring my ethernet network (because I have no bloody airport card inside it) took a whole hour, and left me with cables scattered from one end of the house to the other.

    So there. I bought a computer that sits there, not willing to connect to any external hdds or printers off my network. It is being as stubborn as ****, and the most amusing thing about it at the moment is that marble game that came preloaded on to it!

    Please guys, can you help me out here, because you would of thought a powered usb hub with a Y-split usb cable for double the power would be enough for the simple task of running my WD Passport!

    At this stage:
    Was it worth the money spent: NO
    Does it actually do anything that benefits me: NO
    Why do I have to buy one million pieces of software to get up to installing Leopard: I HAVE NO FRIGGING IDEA!

    Please guys, make it worthwhile for my mac experience.


    Thankyou and goodnight.
     
  2. Fallinangel macrumors regular

    Fallinangel

    Joined:
    Dec 21, 2005
    #2
    You didn't buy a new, Intel Mac Mini, did you?
    Why would you nowadays buy a Mac Mini with an outdated G4 PowerPC architecture inside and only 512MB RAM?!
    How much did you pay for it?

    Anyway, you should try if your USB ports work at all. A USB thumb drive would make a good test object.
    Your Mac Mini is already quite old and the ports might be broken.
    Normally, connecting an external hard-drive or a printer should be no problem at all. Even NTFS in readable, though not writable on OS X.

    You don't have to buy any software to be able to install Leopard!!!
    Just mount the DVD and start the Installation right away.
    However, keep in mind that it won't perform very good on your computer because you only meet the very, very minimal requirements.
     
  3. SmurfBoxMasta macrumors 65816

    SmurfBoxMasta

    Joined:
    Nov 24, 2005
    Location:
    I'm only really here at night.
    #3
    You apparently either:

    A) Bought a lemon

    B) Have Ø patience, and/or

    C) Have Ø working knowledge of logical, systematic troubleshooting procedures, especially on macs

    The tone of your complaints make you sound alot like a clueless peecee troll looking for a fight. If so, go away....very far away NOW :p

    If not, then take your meds and calm down.....it's NOT the end of the world that you can't seem to figure out whats wrong with your setup.......frustrating perhaps, but that's just your emotions talking :D

    If you really want some help, try explaining what steps you have taken already, and what exactly works & doesn't work with enough details to enable someone to walk you through some possible resolutions.......theys b some pretty smart folks lurkin 'round here :p
     
  4. gusious macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #4
    Smurf is right dude!

    Calm down and explain to us what happened.

    I've in the situation that you are(being full of nerves and hating macs) but believe me, if you calm down, only then you are going to fix the problem.

    So let's start this over!:)
     
  5. sir Mudkip thread starter macrumors member

    sir Mudkip

    Joined:
    Aug 25, 2008
    Location:
    Adelaide, Australia
    #5
    Ok sorry, I was getting a little tired of the whole thing

    a) I bought it for $350 aud. Not bad by my books, but is there a way to install a intel processer?

    Here are the steps I have taken

    1. Plugged my wd passport into both of my usb ports. Nothing happened.
    Plugged it into the usb ports on my keyboard. Still nothing.
    Pulled out my usb hub (it is powered and tested and all 7 hubs work on my pc). Plugged it into there and leading into the mac mini. Still nothing.
    Pulled out my pen drive. Plugged it in to the computer itself. Automatically detected.

    2. Did a fat32 format of the passport. Plugged it in. Still nothing, Disk Utility took no notice.

    3. Have no warranty left so thought no use replacing.

    4. Did a google for mac drivers. Naught there.

    5. Plugged in my iPod. Seemed to work.

    6. Plugged in camera. Worked fine.

    7. did a reboot and tried all steps again in a different powerpoint.
     
  6. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #6
    No

    Your USB ports seem to be working, so I can think of no good reason why your external disks should not mount OK. No drivers are required for them to work. Did you re-install OS X when you got your Mini? If not, then at this point I think I would go for a re-install.

    Edit: One more place to look to see if your Mini can see the drive - Apple Menu>About this Mac, Click on "More Info" which will load the System Profiler application. If you click on "USB" in the Hardware list, you should see the drive listed there, which at least would mean that the Mac can see it's plugged in
     
  7. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
  8. Andre1980 macrumors member

    Joined:
    Jul 29, 2008
    #8
    I've a similar problem with my (also old) G4 PowerBook when a friend tried to connect his external HD via two USB cords to my machine. No harddrive was detected. I think it's the power of the USB ports is too small. This varies from external to external drive (I now own one which works fine with two USB cables). So maybe it's just that combination of too little power of the USB ports on the mini and a unusual thirsty external harddrive.
    I have no experience with the old G4 minis (the intel ones make no problems when it comes to these USB powered drives), so it's just a guess.
    You don't have a power adapter for that external drive do you?
     
  9. Andre1980 macrumors member

    Joined:
    Jul 29, 2008
    #9
    Is the external hd formatted under vista?
    The new vista format is not readable by macs. At least that's what happened to me when I tried to read a dvd with photos burned under vista on my mac.
     
  10. iToaster macrumors 68000

    iToaster

    Joined:
    May 3, 2007
    Location:
    In front of my MacBook Pro
    #10
    OP, to be honest, a 1.25 GHz G4 in a Mac Mini is not cutting it in speed for the present. Leopard is has a minimum requirement of an 867 MHz G4, so you can install it, but it's never going to be like an intel Mini and there is no way to put an intel processor in a PowerPC made Mini. Benchmarks: your Mini - 700; new Mac Mini - 2500. Of course, on to helping you... if your external hard drives have power supplies, plug them in, USB does not typically supply enough power to run a hard drive.
     
  11. djtrippin macrumors newbie

    Joined:
    Aug 5, 2008
    Location:
    Grand Rapids, MI
    #11
    I Still have my original 1.25GHz G4 mac mini, and it runs leopard decently for what I am using it for however, I upgraded to 1GB ram(absolutely necessary for that model) and I am only using it for running front row across the network to my TV. If you want to use the original Mini for everyday use at this point I would recommend two things.

    1.) Upgrade to 1GB memory, immediately and without blinking. You can get a stick these days for less than the equivalent of 50USD. I'm not sure what the exchange is for AUS$ these days.

    2.) Stick to Tiger, Leopard is too much of a resource hog for the original Mini models, and pretty much every application still supports tiger with a few exceptions.

    As for the external hard drives, reinstall OS X. I never had this problem but I have seen it before on other Macs. I was never able to figure out the problem, but whenever I have witnessed it, reinstalling OS X fixed the problem, so I would assume it is probably caused by some system file being corrupted or a settings conflict. Not sure.

    The introduction of the Mini spurred my switch to macs, so I am partial to it, but it is still a legitimately decent machine for the price. Just remember, this is nearly 4 years old, and built from budget laptop hardware, so it was a year or two behind the hardware curve from Day 1. If you keep that in mind and outfit it accordingly with more conservative software and a memory upgrade, I think you will find it to be a considerably effective mac at it's price point still to this day.
     
  12. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #12
    I got myself a 1.42 GHz Mac Mini in early Summer 2007 and it works like a dream.

    It never gets turned off and stays on 24/7. The only time I reboot it are when software updates tell me to. I use it for web browsing, emails, music, movie watching, messaging and more. I use it for doing custom firmware on my PSP and for Pwning my iPhone.

    I put 1 Gb of Ram in it straight away. I'm on the latest version of Leopard, 10.5.4 and use a WD Passport 120Gb external Hard Drive for Time Machine.

    Now to get the external HD to work I had to have it plugged into the rear USB ports of the Mac. It doesn't work through unpowered USB hubs or the USB ports on the keyboard. I also have a powered 8 port USB hub.

    It doesn't have an Airport Card with Bluetooth so I connect to my wireless network through a Sitecom 54g Turbo wireless USB adaptor. I also connect to Bluetooth via a very cheap USB Bluetooth adaptor.

    Overall i love this little box - once/if it dies I'll get myself a Macbook but until then I'm perfectly happy with this.
     
  13. Cabbit macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #13
    I remember the 10.4.10 update nacking some peoples USB drivers up as the system level ones where replaced an the solution was to reinstall 10.4.9.
    This was caused by having the drives installed during the upgrade procedure and also in some cases due to the drives having a old firmware version.
     
  14. AppliedMicro macrumors 6502a

    Joined:
    Aug 17, 2008
    #14
    To the original post:

    If the drives aren't spinning up on the Mac but do on other computers, it's most likely a power issue. 2.5" drives draw more power than USB specifications allow (500mA if I'm not mistaken). And as far as I know, a Y-cable doesn't supply double that (at least... it shouldn't by specs), but only some 100mA more, without some handshaking via USB. Essentially you're trying to operate your drive beyond USB specs. Which still works fine on most computers. But there's no denying that especially PowerPC-Macs pose problems... Anyway... does the drive work on the powered hub, when connected to the PC?

    As for the issue with ethernet configuration, I cannot really comprehend or imagine why that would take a whole hour ever. If you do have sufficient knowledge of PC networking, that is. Sorry to say, but I don't see why Macs or Mac OS X should be blamed for that. Cameras which mount as mass storage devices can synced with iPhoto. If your camera doesn't but instead uses some proprietary software, there might be only so much Apple can do about it. Then it's a question of the manufacturer providing drivers. The same goes for your phone (it still might have been crippled by some OEM/operator-branded firmware).

    Let me say, that I'm far from being somebody defending Apple tooth and nail every time. And of course, the USB ports' power supply is inconveniently low on some PowerPC Macs. Still... don't blame Apple for everything just yet.
     

Share This Page