Resolved Beige G3 nightmare... nonstop problems!!! (Resolved: Bad PSU)

Discussion in 'PowerPC Macs' started by poiihy, Dec 22, 2014.

  1. poiihy, Dec 22, 2014
    Last edited: Dec 23, 2014

    poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #1
    Please read entire post and thread before writing a reply.
    Things keep changing so you must read all posts.


    So... a few days ago, I worked on my beige g3. I put in my 2 AA battery pack and connected to the PRAM, but the flickering connection corrputed the PRAM. No problem though, a PRAM reset solved it.
    The machine started getting all wonky and sometimes it would work and sometimes it wouldn't (more about this later). One time it managed to, kind of, boot into the OS 9 folder, but then got stuck and never did that again. After a few tries to boot it just got stuck at a white screen with a '_' (underscore) in the upper left corner. So I reseated all the RAM and the VRAM and the voltage regulator thing, and then after that it worked. Now here is a weird thing that happened: the machine tried to boot into OS X like it always would do--get stuck at the happy face--but then it restarted and came back with the floppy with the question mark on it. And it always did this since.
    I booted into the OS install disk, and tested the hard drives; they were fine. I didn't have time to go through an OS X install so I put it away and did it another day.
    Few days later I had time to install OS X, and booted up... and guess what? The optical drive decided to randomly go kaput out of the blue.
    So this is my problem... when I put a CD in the disk drive, it seems to spin at a low speed and I hear the I/O lens move every ~5 seconds. The 'Busy' light stays illuminated constantly. When I eject the disk and then close the tray (with no disk in it), sometimes the motor would spin up to a high speed for a moment. This only happens sometimes when I close it, but not always.
    I thought some dust may have gotten on the lens, so I took it apart to see what I could get to. I went as far as removing both circuit boards and removing some dust but no farther than that. There was a loose piece of plastic bouncing around, which was always there, that I got out.
    After I put the thing back together, the disk drive seemed to work properly now... BUT NOW THE DAMN G3 DIDNT WORK! After repeated restarting and trying different things, the G3 worked again BUT NOW THE DISK DRIVE DONT WORK AGAIN! :mad: So I made a lens cleaner disk and tried that, but it did not work. It did fix my MacBook Pro ODD though :) .
    This ODD is a Pioneer DVD-RW drive, CODE DVR-A05, MFD. Jan 2003.
    All through this the machine would not always boot... sometimes it would boot fine (to the question mark floppy), sometimes it would power on but not show any display, sometimes it would do the same but make a glass-breaking sound, and sometimes it would boot to a blank screen with a '_' (underscore) in the upper right corner. And I think it may randomly shut down too... I've had it shut down a couple times when it started with no display appear. It's all random. Could it be bad RAM?
    I've had random freezing problems before this when the Jaguar install worked; it seemed to happen after I installed 10.2.8 but it froze in the installer too so it is not software.
    So these are the two problems I need fixing:
    1. ODD doesn't wanna work
    2. Machine randomly fails to boot sometimes
    I care more about the ODD and if the machine is completely kaput, I still want a functional ODD.
     
  2. bunnspecial macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #2
    The random shut-offs would lead me to think the PSU is on its way out...a failing PSU can cause all sorts of strange and often inexplicable things to happen.
     
  3. poiihy, Dec 22, 2014
    Last edited: Dec 22, 2014

    poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #3
    I have done some experimenting just now

    Trial 1... Machine boots to blank screen with '_' (underscore) in upper left corner. Could not shut down machine with button, had to pull plug.

    2... Plugged machine back in after few seconds. Machine did not boot when pressing power button, but then booted a little while afterwards without me pressing the button. No display comes up. Had to pull plug again and wait.

    3... This time I removed the added VRAM module (I think it has built-in VRAM and the slot is for extra VRAM). Plugged in and pressed button and screen comes up... blank screen with underscore in upper left corner again. Power button shutted down machine this time. Unplugged machine and putted back extra VRAM module.

    4... Plugged machine in and pressed power button. Underscore again. :mad: Button worked to shut down machine.

    5... Powered up machine (did not unplug) and same thing as 4 again.

    6... Powered up machine by keyboard button and conducted PRAM procedure (CMD+OPT+P+R). Machine ignored PRAM reset and stuck at underscore screen again.

    7... Underscore screen again

    8... Underscore screen again.

    9... Underscore screen again, and ODD tries to read OS X disk.

    10... Unplugged machine, disconnected all drives, replugged machine, and booted. Same thing.

    11... Removed added VRAM and Removed two sticks of RAM, leaving the middle one (64MB). Booted and machine launched normally; to the question mark floppy. Now i'm getting somewhere :D

    12... Replaced (put back) the VRAM module and the leftmost RAM stick (32MB). Booted normally again.

    13... Replaced the rightmost RAM stick (32MB), booted, and got underscore screen. I think I found the culprit! :D This stick of RAM looks like some cheap RAM. This is a 32MB module. I'll post a picture later.

    14... Test the leftmost module (32MB) and works too. The leftmost 32MB module and the middle 64MB module are both fine, but the rightmost 32MB module is bad.


    So it looks like I solved the wonkyness problem of the beige G3, but I still have the ODD to fix.
    But here's another little problem... Now that I found that a 32MB module is bad, I now only have 96MB which is not enough for Jaguar. Looks like this machine will be limited to being an OS 9 machine (I really hate classic Mac OS).


    ----------

    That is a possibility... I saw what looked like a leaked capacitor in the PSU, but that was always there (since I got it out of storage at least). I think the more likely problem is that bad RAM stick that I fixed.
     
  4. poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #4
    Ok so I reinstalled all drives and now it is running normally again, BUT the ODD is still kaput and I need someone to help me fix that.

    BTW... This machine has an 80MB Quantum Prodrive LPS that randomly stopped working. When I first installed OS X it was working fine, but after a little while it randomly stopped appearing. I didnt have time to tinker with it as I was just about to pack it up to bring it here. It's just an 80MB drive with nothing on it so I don't care much about it but i was just wondering why it randomly stopped appearing.
     
  5. poiihy, Dec 23, 2014
    Last edited: Dec 23, 2014

    poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #5
    Today i booted my machine and the disk drive worked now but the machine booted to a blank screen with no boot chime nor light. I had to pull the plug!!

    Ugh WHAT IS WRONG NOW? :mad:
     
  6. poiihy, Dec 23, 2014
    Last edited: Dec 23, 2014

    poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #6
    Tried a second time and same thing! :mad:

    Except this time it let me shut off with power button.



    Started again and same thing, but could not turn off with power button and had to pull plug.

    UGH! When machine works the ODD DOESN'T WORK, and when the ODD DOES work, the BLODDY MACHINE DOESN'T WORK!
    ┻━┻ ︵ヽ(`Д´)ノ︵ ┻━┻
     
  7. comda macrumors 6502a

    comda

    Joined:
    Mar 15, 2011
    #7
    I would Agree this is a Power Supply issue. I had the same issue with my dads Old Pentium 1. I realize this isnt a Power Pc but same idea. The machine began to act up and freeze up at times then eventually began to shut off on its own. When i tried diagnosing the problem by stripping it to its bare min requirements to post and boot i found once i added the hard drive back it wouldnt boot. I tried it with a Different PSU and problem solved. TUrns out a few Caps had been leaking inside the PSU.
     
  8. poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #8
    I think you must be right, because there is what appears to be a leaking capacitor inside the PSU. I just didn't think it would cause problems because I hadn't had any problems at first. Maybe the PSU destroyed that RAM stick. Maybe it destroyed more than the RAM stick. :eek: And maybe that's why the ODD was acting funny... didnt get enough power! Sure sounds like it! Well thanks MacRumors.

    Now I only have ONE PPC Mac that actually works :confused:
     
  9. catzilla macrumors 6502

    catzilla

    Joined:
    Dec 15, 2013
    Location:
    Rhode Island
    #9
    Is this a tower or desktop? There is a jumper on the logic board to use a regular ATX PS, IIRC.
     
  10. poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #10
    This is a desktop

    Also, I looked in the PSU with a flashlight and saw many more leaked capacitors! Yeeeech :confused:
     

Share This Page