Bejeweled2 stopped working

Discussion in 'iPod touch' started by thornev, Jan 3, 2009.

  1. thornev macrumors member

    Joined:
    Dec 31, 2008
    Location:
    Upstate New York
    #1
    When I touch the Bejeweled2 icon, I get the Pop Cap splash screen that says "Loading" and then the Touch goes back to the main screen. Can I find a copy of the app and reinstall it? If I download I hope I don't get charged for it since it came on the Touch 2G. Thanks for any help solving this problem. thorne
     
  2. iTzChasE macrumors 6502

    iTzChasE

    Joined:
    Dec 31, 2008
    #2
    Uninstall the app, then Reinstall it.

    Edit: did you try to shut if off then turn it back on?
     
  3. thornev thread starter macrumors member

    Joined:
    Dec 31, 2008
    Location:
    Upstate New York
    #3
    Yes, I shut the Touch off (held on/off button until it turned off) and back on - no change. How do I reinstall since it's not in my Applications list in iTunes? Reinstall from a backup folder somewhere? Need instructions please. I'm on Windows XP. thorne
     
  4. iTzChasE macrumors 6502

    iTzChasE

    Joined:
    Dec 31, 2008
    #4
    You don't have to do anything with itunes..

    Delete the App... Touch the screen and wait untill all the icons start to wiggle.
    Press the X and delete the app
    Go into the app store, and re download it....
     
  5. iTzChasE macrumors 6502

    iTzChasE

    Joined:
    Dec 31, 2008
    #5
    This is what it looks like when you do it.
     

    Attached Files:

  6. thornev thread starter macrumors member

    Joined:
    Dec 31, 2008
    Location:
    Upstate New York
    #6
    Thanks. That did it. I hope it doesn't suddenly stop working again. thorne
     

Share This Page