Belkin F7D4401 Modem Router (Play Max) doesn't do Bonjour! - EDIT: Now it does!

Discussion in 'Mac Accessories' started by Claudio2010, Dec 20, 2010.

  1. Claudio2010, Dec 20, 2010
    Last edited: Jan 12, 2011

    Claudio2010 macrumors newbie

    Jun 8, 2010
    Hi everyone,

    In case you were considering getting Belkin's router, here is a note I just got from their customer support.

    Dear Belkin User,

    Thank you for contacting Belkin Technical Support.

    I see that you are not able to access the bonjour services on the router F7D4401.

    Well F7D4401 does not support Bonjour services,We are aware of the issue and We are working on a firmware release regarding the issue.

    If released you can find it on the

    I wasn't expecting this from a router sporting the 'mac compatible' logo on the box. Hope it helps.
    Can anyone suggest a good adsl modem/router? It would be neat if there was a version of the airport extreme with an integrated adsl modem.

    EDIT: Latest firmware, version 1.00.46, fixes the issue
  2. colinwil macrumors regular

    Nov 15, 2010
    Reading, UK
    Many thanks for posting this. I have been struggling to get my Apple TV to see my Macbook Pro, and am using this router.

    I've found that my Macbook won't see the Apple TV if they are both plugged (wired) into the router, or one or both of them is connected wirelessly. However, if I plug a 4 port gigabit switch into the router and plug the devices into that, then they can see each other.

    There's a firmware update in the Belkin site with version 1.00.45. I'm wondering if this will help (my Router was shipped with v 1.00.39 even though I only purchased it last week). I'm downloading it now.
  3. colinwil macrumors regular

    Nov 15, 2010
    Reading, UK
    ps. I've updated the firmware to 1.00.45, and it hasn't helped the 'Bonjour' issue. I've contacted Belkin to find out if a further update will be available (to support Bonjour). Hopefully it'll add weight to your request!
  4. Claudio2010 thread starter macrumors newbie

    Jun 8, 2010
    Thank you for your feedback colinwil. My firmware is 1.00.39 so I'll update it too. I bought the router a couple of weeks ago too. I must say I'm not happy with it, I'm also getting occasional wireless disconnections. It's strange as the airport icon on the menu reports connected with all bars lit, but I can't access Internet or my local network at all.
    I also wish the MAC address filtering could somehow address only wireless devices, instead you need to list all MAC addresses of all devices you want to allow on the network.
    I hope the update will fix the stability issues!
    And thanks for contacting Belkin too!
  5. cabbageprince macrumors newbie

    Jan 3, 2011
    Finding more ad more things wrong with this router....wasn't the cheapest so expecting more from it.

    I'm running an iTunes streaming server (firefly) on a Netgear ReadyNAS and it can't be detected from iTunes on my Windows Vista Laptop.

    Guess uses Bonjour to detect the server....

    Just sent a ticket to Belkin to complain about this and asking about any firmware updates to fix this issue....

    My first issue was that Jumbo frames are not supported on this router....strange for it to have a gigabit switch and this not be supported.

    And now this....will update this with their response. I expect I will get the same as above!

    Edit: JUst tried running a direct link to my server missig out the router and it does work perfectly so definitely a problem with this router.
  6. gvano24306 macrumors newbie

    Jan 5, 2011
    NO JOY with Play N600 router model f7d8302 (and poss all N600)

    I hope the following will save others with this issue from getting grey hair....

    Glen: I have a question about my Belkin router and compatibility with Itunes home sharing and/or bonjour.

    Mudasar: I will be happy to help you with the issue.

    Mudasar: Please let me know the issue

    Glen: I have my old "slow" netgear router hooked up and everything works fine. I put in my new Belkin router, everything works fine except Itunes home sharing. I put in my old router again, and everything works.

    Glen: Seems like there is not any new firmware for this router, is there a compatibility issue with "bonjour"/Itunes home sharing with my play N600?

    Mudasar: Could you please confirm if the product is F7D8302 ?

    Glen: yes, it is correct

    Mudasar: I would like to inform you that the Belkin F7D8302 router does not support bonjour.

    Glen: Thank you very much for this information, you just saved me alot of time...
  7. cabbageprince macrumors newbie

    Jan 3, 2011
    My response from Belkin about the f7d4401
    Based on the information provided, I understand that you are facing problemprobelm in using the iTunes with the Belkin router.

    Let me assist you with this issue.

    We are sorry to state that the Belkin router F7D4401, does not support Bonjour services. However, our product development team is working on the same and the future firmware update would fix this issue.

    At least they're looking into it but people have been getting this response since October last year when looking on other forums.
  8. Claudio2010 thread starter macrumors newbie

    Jun 8, 2010

    Pretty appalling. That 'Mac Certified' logo they have on the box should definitely be removed.
    I have disabled the 'self healing' feature and discovered that the modem will occasionally disconnect from the internet, I have seen this happening roughly once or twice a week. I guess Belkin knows it's an unreliable apparatus as they stuck in a feature to reboot it periodically. My old Robotics never had a glitch and it would be on for months at a time.
    Also, the 'check for new firmware' feature does not work, colinwil pointed out that a new version was available.

    I think I will throw it out soon. Can anyone recommend a good modem/router? I prefer having an integrated solution and not two separate pieces of hardware.
  9. colinwil macrumors regular

    Nov 15, 2010
    Reading, UK
    New F7D4401 firmware released today

    Some news - Belkin have today posted a firmware update for the Play Max N600 (F7d4401uk) router - version 1.00.46. The release notes say:

    * Fixes PPTP VPN connection issue
    * Fixes MTU issue which could prevent certain sites from loading
    * Fixes library sharing issue in conjunction with iTunes
    * Miscellaneous bug fixes

    Who knows whether the third point means they fixed the Bonjour discovery problems? and hence AirPrint. I'll test it as soon as I get home
  10. colinwil macrumors regular

    Nov 15, 2010
    Reading, UK
    The firmware update for the F7D4401uk Belkin router has fixed all my problems with Bonjour, Airprint, Airplay streaming, shared iTunes libraries etc. Great news!

    To make things as hard as possible for the router, I connected my Macbook, wired to the router, the Apple TV wired to a switch that's wired to the router. My iPhone was connected to the 2.4Mhz wifi & my iPad was connected to the 5Mhz wifi. Everything worked seamlessly:

    * I can print from my iPad and my iPhone via airprint to the printer connected to my Macbook (which has Airprint Activator)

    * I can stream movies from my iPad to the apple tv.

    * The Apple Remote app controls the Apple TV fine from both the iPad & iPhone

    * iTunes on both my macbook & PC can see a shared iTunes library I have on an Iomega home storage NAS box

    * iTunes on both my macbook & PC can see each others libraries

    * The Apple TV can see the libraries on my macbook and my PC.

    * The printer is attached to the USB port on the router. It works fine like that from both my Macbook & PC. even scanning works (it's an all-in-one)

    I'm a happy bunny! :D
  11. Claudio2010 thread starter macrumors newbie

    Jun 8, 2010
    Thank you once again for pointing it out colinwill. Bonjour does indeed (finally!) work. I don't know whether pestering them with the issue helped, thank you and the others anyway for writing to Belkin support.

    One added feature I enjoy about the router is that it gives you a layman's NAS if you plug in a USB drive. It also supports read/write on NTFS formatted drives, wherea OSX only lets you read (unless you do some tweaking)

  12. daleski75 macrumors 68000


    Dec 10, 2008
    Northampton, UK
    Hopefully this new firmware will fix the MTU issues I have with Sky Broadband

Share This Page