Belkin N52 and OSX Snow Leopard

Discussion in 'Mac and PC Games' started by Snoball, Dec 31, 2009.

  1. Snoball macrumors newbie

    Nov 17, 2009
    Has anyone been able to get the Belkin N52 (not the newer N52 TE) to work under Snow Leopard? I tried to install the driver but get an error message that the .kext file was not installed correctly. (Yes, I am running in 32 bit mode).

    Belkin tech support claims the N52 is not compatible, but I am finding posts in various forums that lead me to believe others have in fact gotten the driver installed and working under 10.6.

    Unfortunately I haven't had any luck getting anyone to respond in any of the other forums with a valid work around to the problem.
  2. mooikiye macrumors newbie

    Jan 2, 2010
    It is possible as I have the original n52 running on SL. I am not sure there was anything that I had to do special. I have a system preference that is 32-bit for the nostromo array. Think I just downloaded the mac driver from the belkin site.
  3. Snoball thread starter macrumors newbie

    Nov 17, 2009
    Darn....this is upsetting, as I really rely on my Nostromo to play Wow, and I can't get even the most recent driver installed without getting errors. I was wondering why I hadn't seen more complaints on the net about this (which is why I made this post). Strangely, the Belkin rep I spoke with flat out said the controller wasn't SL compatible.....which is a nice way of saying "Sorry, I really don't feel like helping you".

  4. Snoball thread starter macrumors newbie

    Nov 17, 2009

    Did you get the N52 driver installed under Leopard, then upgrade to SL.....or did you install it under SL?
  5. Fnord macrumors member


    Aug 12, 2005
    What versions of the Nostromo Array software are each of you using? I haven't upgraded to Snow Leopard yet, but will be soon, so I'm very interested in keeping my n52 working when I do.

    I'm currently using the 1.1 version of Nostromo Array under Leopard, will I need to upgrade to version 2.0 before upgrading to Snow Leopard?

    Version Tracker seems to have all three versions of Nostromo Array still available (1.0.1, 1.1 and 2.0):
  6. Snoball thread starter macrumors newbie

    Nov 17, 2009

    I downloaded and installed version 2. It was what Belkin had on their support site. The compressed packaged was named nostromo-array-20-d05.dmg, which I just verified is the version 2 file on version tracker.

    Running 10.6.2 on a 13" MBP.
  7. Snoball thread starter macrumors newbie

    Nov 17, 2009
    BTW.........It looks like ControllerMate is really the only option for 10.6. While it does the trick, it is a little convoluted to get set up. Also, it costs $15. Small price to pay to be able to use SL on my machine, but it still pisses me off that Belkin has done such a poor job support the N52 on the Mac.

    I'll never buy another Belkin product again. If in fact I purchase another speedpad type device, it'll be this logitech model, which looks much nicer anyway:
  8. Tigerman82 macrumors 6502

    Jul 27, 2010
    I recently bought the new mid-2010 iMac. As I was able to get games like Half-Life 2 and CS: Source as OS X -versions from Steam, I wanted to bring out from retirement my trusty N52 (original) that I had previously used a few years ago with a Windows XP laptop. I read from the Net that this controller isn't exactly problem-free in OS X and that I might not be able to get it to work under Snow Leopard. I started thinking about buying the TE-version but it seem to have problems as well. I considered Logitech G13 but I cannot really justify the price (I'm a casual gamer). I read about Controllermate but it seemed that it would not guarantee me anything with the N52.

    Anyway, I decided to bite the bullet and installed the latest version of the Nostromo Array program (downloaded it via version tracker). It installed okey although I got the "Nostromo.kext" error message. I found a thread that offered a fix to this if it happened (I had already checked that my 'kernel' is 32-bit) but I already had the rights as they should be (according to the fix). I rebooted, plugged in the N52 and opened Nostromo Array (which did the whole 'you have restart system preferences' thing). I was able to map the keys and test it playing CS: Source and it worked fine.

    Perhaps I'd be more secure using a brand new iMac with a newer controller but these things (such as Logitech G13) are expensive. I'm a little older now and perhaps passed my gaming phase of life. However, I would like to sometimes be able to play CS and HL2 and luckily I can play them without having to buy another gaming keyboard. I could use my regular keyboard (Logitech Dinovo Mac Edition) for gaming but I don't want to stress it too much (gamers tend to hit the keys harder).
  9. artstu macrumors newbie

    Feb 7, 2008
    I've just dusted off my old n52 to use with my 2008 Mac Pro [OSX 10.6.5] and installed the driver from the Belkin website. First time, It gave an error message saying that the .kext file was incompatible, but I tried again and it installed okay and seems to be working fine now.

    I am a little worried how long it's going to remain compatible, however, but for now all seems well.
  10. digsafe macrumors newbie

    Jul 23, 2011

    I am so disappointed. I use my n52 all the time and am crushed that it won't work on my new 27" iMac. I own 2 of them and use them primarily for work as a repository of keyboard shortcuts. I've been using them for years and they have saved me countless hours in increased productivity.
    I saw that razer is selling it now but without and mac support.
  11. Beaverman3001 macrumors 6502

    May 20, 2010
    The n52te works great under Snow Leopard and Lion.
  12. garex macrumors newbie

    Sep 20, 2011
    Lion and n52te - got it working again.

    Hi folks,

    Without any logic in it this is how I got the nostromo n52te working again in Lion 10.7.1:

    - there was an issue with some permissions and my mac was reacting weird.
    - booting from the recovery hd partition
    - the n52te was currently plugged off my belkin usb hub, but the not-working-drivers were installed.
    - repaired hd & permissions in disk utility (exactly in this order)
    - reboot
    - accidentally looked into my account preferences and saw a startup item called "n52teHelper", which I kicked out, because the n52te was not working any more.
    - then I did another test reboot due to my weird mac behaviour.
    - and now I sighed and thought how nice times were when I was playing with my n52te. :) and I plugged it into my Belkin USB hub, looked for the preferences, fired up World of Warcraft for a hopefully successful test and TADAAAA!! - it worked!

    So it has to do with this n52teHelper thingie. because when I looked again, it was re-enabled in the startup items and when this happens, the n52te does not work, when it is started during login.

    Maybe this gives you an idea. Don't ask me, me as a sysadmin finds this behaviour not only strange but really weird. :)
  13. TallManNY macrumors 601


    Nov 5, 2007
    Hmm, seems complicated. I can't get my Nostrom to work on my new iMac, which I then upgraded to Lion. I don't want to play Wow without that or a similar controller (it is the way I learned to play and I think it is superior to using the keyboard, I also use razor 18 button gaming mouse for my right hand, I think every skill needs to be available and you need to be able to touchtype play them).

    I will give the Nostrom another try but if others have solutions please post. I'm also happy to buy a newer similar device if that will work, but it tends to be the older devices that have the Mac drivers.
  14. garex macrumors newbie

    Sep 20, 2011
    Ok, here is my way after a logic based analysis.

    - If you use a USB Hub from Belkin as I do, unplug all other gaming consoles like the Wolfking Warrior II (it disturbed the n52te in being recognized, especial with its lighting on!), except your mouse and your keyboard. Put the mouse and the keyboard in the highest USB port numbers.
    - Boot your Mac.
    - Install the drivers from Belkin. It will complain about a failure for installing, just try it again.
    - Reboot, but instead of booting the OS, boot the Recovery HD.
    - Fix your HD and your permissions (this corrects also some permission issues with the k.ext)
    - NOW plugin your Nostromo n52te in the _lowest_ port of your USB Hub; if it is not recognized as a foreign keyboard, try it later in this how-to.
    - Reboot your Mac
    - Login into your favorite user account
    - If the Nostromo has not been recognized as foreign keyboard before, try it now and plug it in to the lowest Port of your USB Hub and in the next ports the other gaming consoles.
    - Open System Preferences -> Users -> Startup Items and kick off the n52teHelper.
    - Just in case, reboot again.
    - Login into your favorite user account
    - Open System Preferences -> n52te and try to switch profiles. When the LED color changes, you have won. Otherwise I'm sad for you.
  15. megid macrumors newbie

    Mar 30, 2014
    N50 on Mavericks works

    Hi, just for the record, I got my N50 (not even the N52) working on OS X Mavericks, to which I upgraded recently (2014-03). Belkin driver did not work, JoystickMapper did not work, but USB_Overdrive ( does, although in the System Preferences there is a nagging 10-seconds countdown before you can map the N50 keys to keyboard keys.

Share This Page