Belkin Thunderbolt dock issues

Discussion in 'Mac Accessories' started by hehe299792458, May 26, 2013.

  1. hehe299792458 macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #1
    I've had my Belkin Thunderbolt dock for a few weeks now.

    Every 3 or 4 days, the USB ports on the dock would randomly disconnect my peripherals (mouse, keyboard, USB drive). I have to restart the computer to get it working again.

    Is anyone else experiencing similar problems?
     
  2. PJM82 macrumors member

    PJM82

    Joined:
    Apr 28, 2013
    Location:
    United Kingdom
    #2
    Have you installed the latest thunderbolt update?
     
  3. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #3
    yes i have
     
  4. jmill155 macrumors newbie

    Joined:
    May 27, 2013
    Location:
    Virginia beach, VA
    #4
    I was about to get the thunderbolt dock...please let me know if you resolve this issue
     
  5. PJM82 macrumors member

    PJM82

    Joined:
    Apr 28, 2013
    Location:
    United Kingdom
    #5
    I would start working this through with Belkin technical support now. Maybe with the huge delays for this product not everything was solved.
     
  6. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #6
    Are you using a Belkin dock by any chance? If so, are you have any trouble with it?
     
  7. PJM82 macrumors member

    PJM82

    Joined:
    Apr 28, 2013
    Location:
    United Kingdom
    #7
    Not me no, but one of my colleagues had an issue with anything staying connected to his 15 rMBP via this dock. He has simply returned it. Belkin have had reasonable customer services in the past when I've had issues with some of their higher end KVMs.

    Let us know how you get on with Belkin if you decide to stick with it.
     
  8. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #8
    Did his devices not connect at all or did they disconnect after a few days (like mine)?

    I used a Late 2011 MBP if anyone's interested. Running 10.8.3 with the latest updates (including the thunderbolt update) installed.

    Actually, I am a bit suspicious about that last thunderbolt update. I know it was supposed to increase stability, but I only vbegan to have problems after I installed that update.

    But then again, I only had my dock for 2-3 days before I installed the update, so there was not enough time to tell
     
  9. PJM82 macrumors member

    PJM82

    Joined:
    Apr 28, 2013
    Location:
    United Kingdom
    #9
    It was last week and things would randomly disconnect. It didn't seem to take days. He has no patience so it was gone. I suppose if I had spent that money on a dock I wouldn't be too happy either.
     

Share This Page