Belkin wireless router and WEP setup problems

Discussion in 'Mac Basics and Help' started by Will Cheyney, Nov 9, 2005.

  1. Will Cheyney macrumors 6502a

    Will Cheyney

    Jul 13, 2005
    United Kingdom
    My girlfriend has just bought a new Belkin ADSL wireless router for her house. I've been trying to set up a WEP password to prevent unauthorised access from curious neighbours.

    Trouble is, I can't get it to work. Can anyone talk me though the process of doing this?

  2. ElectricSheep macrumors 6502


    Feb 18, 2004
    Wilmington, DE
    You should be aware that when you select an alphanumeric password for use in a WEP encrypted network, the password is hashed into a 128 bit hexadecimal key. This key is then used to encrypt the network.

    The trouble is that Apple uses a different method to hash passwords than Belkin (or most other router vendors). If you try to join the Belkin network with the alphanumeric password, you will not be successful.

    Instead, you need to copy down the full 128 bit hexadecimal key that the Belkin router has generated from the alphanumeric password. This key is what you need to enter into the password dialog when you attempt to join the wireless network.
  3. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
    WEP? That's like looking your door, but leaving the key in the lock. Any 8th grader with a wireless connection, google, and 30 minutes can break into that. Hopefully, that router has WPA or something way more secure than WEP.

    Have you read the manual? Every router has a different configuration. Even different firmware versions of the same router have different configurations. It will be very hard for someone to help you. Read the manual and try it again. If it doesn't work, tell us exactly step-by-step what you did. We can try to help from there.
  4. japasneezemonk macrumors 6502


    Jun 13, 2005
    This might be true, but WEP is better than nothing. WEP wont help stop intruders but it will stop some random amateur who is looking for an open WIFI connection.

    - I would Call Customer Support. I have done this before and Belkin customer support has been very helpful. Plus it's available 24/7.
    -or, Just try what ElectricSheep said, it's better than nothing, but try and call first.
  5. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
    It really isn't that much better than nothing. It won't even stop an amateur if they are willing to do a google search on hacking WEP.
  6. agentphish macrumors 65816


    Sep 7, 2004
    I have your answer.

    We had a similar problem here with a belkin router about a month ago... I could not admin the router from my g5... Im betting whats happening is that its not saving your settings right? when you put in a wep key to tell it to use/save, or any other setttings info for that matter its just not saving it.

    It seems to be a glictch with safari I think. I used a different browser and i was able to do it no problem. I also tried from my powerbook and it worked... Also try from a different mac/pc if you can. See if you can get it to work then.

    Good luck

Share This Page