Bento 3-Unable to lock/encrypt fields

Discussion in 'Mac Apps and Mac App Store' started by markw10, Oct 9, 2009.

  1. markw10 macrumors 6502

    Joined:
    Sep 4, 2006
    #1
    I am using Bento 3 but have been unable to lock/encrypt fields.

    I have already created a password to lock the Database. I am able to lock the database but when I view what's listed as an encrypted field I have an option to lock Bento but there is no option to lock the encrypted field. The lock icon is missing.
    I have looked at the instructions but don't see what I'm doing wrong. Any idea of why I'm not getting this option? Thank you.
     
  2. dws90 macrumors regular

    Joined:
    Jan 16, 2008
    #2
    In form view, to the right of the field there should be an icon that looks like a down arrow. When you click it, "Lock Encrypted Fields" should be one of the options. Is that icon not showing up?

    You may want to try creating a new encrypted field. It's possible the field you think is encrypted is really just a regular text field.
     
  3. markw10 thread starter macrumors 6502

    Joined:
    Sep 4, 2006
    #3
    Thank you for your response. I get the down arrow but all it says is:
    Show Encrypted Field Comments
    Lock Bento
    Copy Field Contacts to Clipboard

    It doesn't show the option to encrypt the field.
    Also, if I'm correct there should be 3 choices for the eye, an open eye, a closed eye, and a lock. I don't get the lock.

    I tried creating a new one but it didn't solve the problem.
    I had Bento 2 and upgraded to Bento 3 which I know added this option. I don't know if maybe there could be a bug or either something wrong with the install but I even did a google search and it doesn't seem like other people are having this issue.
     
  4. dws90 macrumors regular

    Joined:
    Jan 16, 2008
    #4
    What's currently visible in the field? Does it show the actual text or is it just a bunch of dots? Choose "Lock Bento" from the dropdown. What's visible then?
     
  5. markw10 thread starter macrumors 6502

    Joined:
    Sep 4, 2006
    #5
    When I went back and deleted all the encrypted fields from the database and cleared the database password to start everything over, it then lists 'lock encrypted fields' as an option.
    Then I chose new library from template and chose user name and passwords. It shows lock encrypted fields in the password field.
    The question then becomes: Under security I am not requiring database password when Bento starts. Is it possible to require database password when Bento starts and lock encrypted fields at the same time?
     

Share This Page