Best performance for Adobe after effects CS6?

Discussion in 'Mac Pro' started by macguy93, Nov 13, 2012.

  1. macguy93 macrumors regular

    Jul 30, 2012
    Hello everyone,

    I feel as if i keep making similar posts to this, but for some reason i am still not satisfied with my machine. Im using a mac pro 12-core 2.4GHz with 40gigs of ram installed.

    I finally got around to getting my SSD set up and i have all of my applications installed on it along with the OS. i also have all of my cache files set to my WD hard drive so I'm not clogging up my 120GB SSD. My SSD has 40gigs left so i figure i shouldn't go any lower than that to keep the performance of the drive at its fullest potential.

    I do a lot of work in after effects CS6 and i feel that the machine is still going slow.. I was working on a project last night and when i went to do a RAM preview i kept getting the beach ball and after effects would glitch up.. what would be the main cause of this? could it have been that the destination file i was working with was on my WD drive and not the SSD?

    I don't know what it is i need to keep adding to this machine to finally be satisfied with its performance.. My next investment would most likely be a GTX 570 to enable CUDA cores for open GL rendering, but i still feel that i should still be getting great performance now.

    Any suggestions? maybe I'm doing something wrong?

    Thanks in advance!
  2. smdonnel macrumors newbie

    Oct 22, 2012
    Probably your disc caching

    From what you have written and what I have read other places you might want to have your caching set up to go to the ssd. Im running Cs6 on a 2009 imac and it screams. Cant wait to get a new machine with a solid state drive to cache to.
  3. thekev macrumors 604


    Aug 5, 2010
    OpenGL and CUDA are totally different things. Both are only usable for certain things, so prior to such an investment, you should ensure that it will actually benefit you.
  4. wonderspark macrumors 68040


    Feb 4, 2010
    I use a 2009 Mac Pro that I upgraded to a 6-core CPU and 5870 for After Effects heavily. I only have 32GB of RAM, but I found a couple things that helped quite a bit:

    1) Setting aside 6GB for other applications. This limits AE to only 26GB, but I stopped having crashes after changing this. I also have no page outs or swap file use this way, and the most I've seen my system use with AE and Premiere open is 29GB.

    2) Setting aside "4 CPUs" for other applications. The system thinks I have 12 CPUs due to hyperthreading on 6 cores, and I allow only 8 threads to run simultaneously by checking the "Render Multiple Frames Simultaneously" and keeping four aside. The reasoning is similar to setting RAM aside... prevent crashes from AE sucking up all the available RAM and CPUs.

    3) 2GB RAM allocation per background CPU. I tested every combination on my 6-core system, and this one was fastest. When changing this, I could double or triple the time it took to render a comp.

    4) I have an 8-disk RAID 6 tower that holds my media, previews and scratch files, along with a second volume for media cache files in a 2-disk RAID 0 internally. Providing plenty of fast space lets me play DSLR footage from a 5DII natively at full resolution without even rendering it out, and that's software-only CUDA acceleration in Premiere. (AE doesn't use CUDA as far as I know, anyway.)

    This is on dual monitors (one being a 30" ACD) hooked to the 5870. I get no beachballs in RAM previews or anything. It's nothing short of wonderful.

    I hope it helps!
  5. initialsBB macrumors 6502a

    Oct 18, 2010
    I had a similar setup at work that was giving me great pains. It was a real let down considering the price paid. You need to follow the above recommendations, it covers all the bases. Also consider getting an SSD for the scratch disks and media caches. If you still get kernel panics, check your RAM to make sure there is no faulty stick as well. It turns out that on the setup I was using one of the sticks was bad, but we only found out much later, and that was causing kernel panics. Note also some AE plugins and effects don't like multi-frame rendering.

Share This Page