Best Powered USB 3.0 Hub?

Discussion in 'MacBook Pro' started by awparker85, Jun 1, 2015.

  1. awparker85 macrumors newbie

    Joined:
    Sep 12, 2011
    #1
    Anyone have any good powered USB 3.0 hubs they can recommend?

    I am currently using a J-Tech USB 3.0 powered hub, but my peripherals keep dropping off and I'm pretty sure it's a power issue. The hub requires it's own power though, so I'm not sure why there's a problem. I'd assuming giving the hub separate power is meant to solve power drain problems, but maybe not. In either case, I'm a bit stumped on how to better manage power there so they don't drop off, or what could work as a better alternative without breaking the bank.

    Thoughts?

    Thanks!
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    I just use a cheap generic $20 4-port USB 3.0 hub (that utilizes a Genesys controller with UASP support, purchased from Woolworths) and it works fine. I've never faced the issue of peripherals getting disconnected with that hub.
     
  3. newellj macrumors 601

    Joined:
    Oct 15, 2014
    Location:
    Boston, MA, US
    #3
    I've had good luck with a SIIG powered USB 3.0 hub with drives and various other peripheral accessories. I can dig up the model number tonight if that's of interest. I bought it to use with a Windows 7 box but it had persistent driver problems. Works like a charm with OS X, though.
     
  4. bfromme, Aug 29, 2015
    Last edited: Aug 29, 2015

    bfromme macrumors newbie

    bfromme

    Joined:
    Jan 15, 2010
    Location:
    NY,NY
    #5
    I recently upgraded my Macbook Pro 13" retina to 10.10.5. Soon after the upgrade time machine complained that it could no longer access the external disk I was using for backups. This disk (WD MyBook 1TB) was attached through the 7-port HooToo USB 3.0 hub. I tried to verify and repair the disk using disk utility and this failed. Worse, the disk could no longer be mounted. I bypassed the HooToo hub and plugged the disk directly into the Mac's USB port and the disk mounted and I was able to run disk utility to repair the disk. To make matters worse, my Macbook Pro would no longer boot with the hub plugged in. I had to unplug the hub, boot, and then plug the hub back in.

    So I contacted HooToo support and they immediately offered to refund my purchase price for the hub. I found this strange, no troubleshooting, just an immediate refund offer! This leads me to believe that they have had many other problems with this hub on Macbook Pro 13" Retina's. When I asked what hub might work, the support person said something like "I don't know, you will have to ask other vendors if they have a compatible chip."

    The reason I bought the HooToo was because it had the only power rating that would cover all of the 7 ports. Most other vendors have too little Volts/Amps to cover all the ports, thus guaranteeing you will have drop offs if you load up the hub with every port filled.

    The strangest thing is that I have had this HooToo 7-port hub for about 10 months and it worked perfectly. It is only when I did the latest upgrade to OSX 10.10.5 that these problems started. Could apple have tweaked the USB drivers for security reasons and screwed up USB 3.0 support? I will be calling AppleCare next.

    So I am back to square one. I need to find a powered USB 3.0 hub that will work reliably on the Macbook Pro 13". Any suggestions?
     

Share This Page