Best settings to stop mac going to sleep

Discussion in 'Apple TV and Home Theater' started by jkeep, Jun 5, 2012.

  1. jkeep macrumors member

    Joined:
    Jul 25, 2011
    #1
    Hi,

    I have just upgraded from ATV1 to an ATV3.
    With the ATV1 having the internal HDD there was never any problem
    with listening to music or watching films I had sinc'd then only woke
    my mac up to watch films on my iTunes library.

    I have noticed that if I want to watch anything on my ATV3 I have to go
    downstairs & wake my mac up before I can do anything.

    I don't mind doing this once when I get home but to do it all the time
    is a frigging pain.

    What are the optimal power settings on my mac or is there another
    way to set it up.

    Cheers,

    Jeff
     
  2. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
    in system preferences on the mac got to system pref - energy saver - that move when on power supply to sleep never, also in there you will see a box to wake on LAN this should wake the mac when your try to access it with the ATV but that doesnt work for me and there are threads where it doesnt work for others, so sleep never is full proff if you dont mind using the power all the time
     
  3. BaggieBoy macrumors 6502

    BaggieBoy

    Joined:
    May 29, 2012
    Location:
    UK
    #3
    In addition, even though I had pwer saving set never to sleep, I was still finding my Mac mini snoozing. In my case it turned out to be caused by my Logitech Harmony remote set-up, when I switched away from the Apple TV activity it was trying to turn off all associated devices.
     
  4. MiamiBourne macrumors regular

    Joined:
    Jan 26, 2009
    #4
    I use a free 3rd party software called Caffeine. It sits in the menu bar and you just click on the coffee icon to turn the feature on (never sleeps mac).

    Works fine for me.
     
  5. maril1111 macrumors 68000

    maril1111

    Joined:
    Mar 14, 2010
    Location:
    Denmark
    #5
    +1 for caffeine, have been using it for years on multiple devices and never had a problem with it.
     
  6. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #6
    I also have my "Computer Sleep" set to "Never" and "Put the hard drive to sleep when possible" set to "30 minutes". I do not have wake for LAN checked. Never had to go and wake up the MBP for the aTV.
     
  7. brucewayne macrumors member

    Joined:
    Nov 8, 2005
    #7
    another +1 for Caffeine (http://lightheadsw.com/) Been using it for a while with no issues. Also gives the option of allowing sleep after X amount of hours, so you have the mac stay awake during the evening but still allow the mac to sleep overnight.
     
  8. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #8
    If you go under "system Preferences" then "Security" and then the "general tab" and make sure you have "Log out after XX minutes of inactivity" unchecked. I learned this on a friends Mac ones that their Mac would log off after so many minutes all the time watching something on their Apple TV. They or myself don't have any 3rd party Apps to keep our Macs from going to sleep.
    What kind of router do you have? Apple routers you can wake your Mac whenever you want to watch something on your Apple TV.
     
  9. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #9
    interesting post maybe thats whats stoping my wake for lan from properly working ill have to check tonight
     
  10. jkeep thread starter macrumors member

    Joined:
    Jul 25, 2011
    #10
    Some great replies, I,ll have a play around tonight when I get home.
    I obviosly want the hard drive to stop spinning & the screen to go
    blank but I also want my ATV to work when I switch my tv on.

    Cheers,

    Jeff
     
  11. Steppy macrumors member

    Joined:
    Nov 21, 2011
    Location:
    Southampton, UK
    #11
    Only thing I don't like about caffeine is that it doesn't let the screen switch off, so I just change my energy settings to 3 hours & that lets the screen switch off as normal but keeps it awake. Once I am done watching a film I just put power setting back to normal and its goes to sleep after 10 mins :)
     
  12. jkeep thread starter macrumors member

    Joined:
    Jul 25, 2011
    #12
    OK, Ive found that if I go to settings and set computer sleep to
    never then I can always access my ATV but..................
    I can always hear my macs fan running in the background when I
    havnt used it for a while, is this doing any harm or shortening the
    life of my beloved mac?
     
  13. thatoneguy82 macrumors 68000

    thatoneguy82

    Joined:
    Jul 23, 2008
    Location:
    Beach Cities, CA
    #13
    These options are interesting, I didn't even know they existed. Like the OP, I too have the same situation. However, I'm almost positive that these options are only for desktop macs. I have a MBP and would like to close the lid and still have access to the media in it. It only works when it's open of course, but I'm pretty sure it's impossible when the lid is closed or is there an app for that?
     
  14. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #14
    InsomniaXwill let you have it set to stay awake even with lid closed
     
  15. kmmingus macrumors newbie

    Joined:
    Nov 23, 2014
    #15
    Please help...

    Did you find a solution to your problem? I think we are experiencing the same issue with our MacMini and logitech remote.
     

Share This Page