best way to downgrade from the newest update.

Discussion in 'Jailbreaks and iOS Hacks' started by tjespo22, Nov 16, 2009.

  1. tjespo22 macrumors 6502a

    tjespo22

    Joined:
    Jun 27, 2007
    Location:
    Staten Island NY
    #1
    this new update messed up my phone and its dropping every single call i make. its on whatever the newest software is i think 3.2.1? anyway, how can i get back to 3.1 or 3.0 and just install the carrier settings that let me mms and tether.
    thanks
     
  2. tjespo22 thread starter macrumors 6502a

    tjespo22

    Joined:
    Jun 27, 2007
    Location:
    Staten Island NY
    #2
    i downloaded 3.1 but i need to just know where to get the carrier settings update.
     
  3. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #3
    You get the carrier settings update to enable MMS through iTunes. I don't believe you can tether on 3.1 without first jailbreaking and installing one of the tethering hacks in Cydia (or Blacksn0w).
     
  4. tjespo22 thread starter macrumors 6502a

    tjespo22

    Joined:
    Jun 27, 2007
    Location:
    Staten Island NY
    #4
    my teathering was working on 3.1 iirc maybe it was 3.0 it was working no problem before mms came out. when mms came out i updated just the carrier settings and turned the phone off then on and mms worked but tethering stopped. whats the trick to downgrade to 3.1? i have the software and also found the thread for the carrier settings to tether and mms http://forums.macrumors.com/showthread.php?t=792894&highlight=mms+teathering

    but when i try to downgrade in itunes it says this device is no elidgeable for this software or something like that..
    thanks
     
  5. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #5
    It sounds like you are using the wrong firmware. What is the *exact* name of the file you are trying to restore to?

    And yes, the tethering hack worked fine in 3.0 and 3.0.1, but starting with 3.1 carrier setting files were checked for a signature. You can't tether unless you jailbreak and install a tethering hack before updating your carrier access settings.
     
  6. tjespo22 thread starter macrumors 6502a

    tjespo22

    Joined:
    Jun 27, 2007
    Location:
    Staten Island NY
    #6
    its iphone 2,1 3.1
    i reset network settings so im hoping this resolves my problem, if not ill be getting a new phone tomorrow from apple. also, what is the EASIEST way to get tethering working in network settings? i dont want to have a 3rd party program i like how it works naturally.. or how it used to work.
    thanks
     
  7. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #7
    You are trying to restore to the 3GS firmware. You need the firmware that starts iPhone1,2
     
  8. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #8
    just so you know when you do downgrade to 3.1 or 3.0 the baseband will not change you will still have the latest baseband
     
  9. iPhone-power macrumors 6502a

    Joined:
    Nov 12, 2009
    #9
    The easiest way is to do sufficient research before attempting this. Sorry, but since you are unable to download the correct version of official Apple IPSW to restore your phone back to vanilla status, it seems you have not bothered to do that.

    The firmware you need is here
     
  10. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #10
    FYI

    2G phone - iphone 1,1

    3G - iphone 1,2

    3GS - iphone 2,1

    Its always wise to double-check your software before you install.
     
  11. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #11
    The devil is in the details...check twice before using firmware.
     

Share This Page