Best way to screen share from a remote Windows machine

Discussion in 'Mac OS X Server, Xserve, and Networking' started by JoelBC, Aug 31, 2014.

  1. JoelBC macrumors 6502a

    Joined:
    Jun 16, 2012
    #1
    The title says it all....

    While at work I am forced to use a Windows computer...is there a way to access my server and screen share with my server and it's connected computers..

    I know that I can VPN into my server but how do I then screen share...help please...

    Thanks,

    Joel
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    I use TeamViewer to do precisely what you're looking to do.
     
  3. JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #3
    Agreed and I know that this can be done but I would very much prefer not using Team Viewer [or LogMeIn or other similar] application...is there an Apple specific application / way of doing this [particularly given this is one of the reasons I am setting up a network in the first place]?

    Thanks.
     
  4. sevoneone macrumors 6502

    Joined:
    May 16, 2010
    #4
    Screen Sharing uses VNC. So you can use any VNC viewer application to remote control your Mac.

    Under Screen Sharing/Remote Management in System preferences you'll find a setting where you can allow VNC users to connect by configuring a password.
     
  5. JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #5
    Sevoneone, appreciate the response and apologies for the follow ups but I am learning all of this as I go so please be patient with me...is my understanding correct that all I need to do is:

    1. Download a Windows VNC client;

    2. Start up and point the VNC client to my OS X Server [i.e. server.macserver.com] [note: OS X Server's screen sharing ports previously opened].

    3. The OS X Server will then ask for my network credentials [i.e. user name and password] just as it would were I starting a screen sharing session from inside / within the network. Presumably this is because the VNC client will send its request to the OS X Server's screen sharing ports by default.

    4. The screen sharing window will then appear!

    If any above is not correct then please correct it!

    Would you have any suggestions as to which Windows based VNC client is best?


    Thanks for everything.


    PS. Any added information or insight you could provide as to how / why the VNC servers request to the OS X Server will be directly to the OS X Server's screen sharing port and thus initiate a screen sharing session would be greatly appreciated as I am struggling with this part.
     
  6. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #6
    On windows I use real VNC and I find it works the best for my needs. However if you are at work you may find you are not be able to use a vmc client because of security protocols or other it restrictions take a look at Chrome Remote Desktop.
    I mainly use apple remote desktop to access my server, but having Chrome Remote Desktop installed also on the server has come in quote handy when I have had issues with ARD.
     
  7. JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #7
    I know that my work router has port 5900 opened so this hopefully will not be a problem but I will need to test this.

    I will try using realVNC from home this afternoon and report back.


    is there a Window's version of ARD as I thought that this was only for the OS X platform?

    Thanks,

    Joel
     
  8. JoelBC, Sep 1, 2014
    Last edited: Sep 1, 2014

    JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #8
    All,

    I am now home and have had an opportunity to try to VNC into my MBA.

    I have however run into a problem noting that I have a MBA connected to my home network as well as a Windows PC connected to the same home network, both via ethernet:

    1. If I try to VNC into my MBA using my Windows PC using my MBA's home network's IP address of 192.168.X.Y (where X and Y are the proper values) then I can connect and successfully control my MBA. This suggest to me that I have the Preferences --> Sharing --> Screen Sharing settings properly configured.

    2. If I try to VNC into my MBA using my Windows PC using my routers public IP address of W.X.Y.Z (where W, X, Y and Z are the proper values) I fail to connect. I get a message that reads "The connection as refused by the host computer".

    Per the below image I have -- I believe -- properly configured the Port Forwarding settings in the router.

    Would appreciate any input / suggestions you have as to how to solve this problem.

    Thanks,

    Joel
     

    Attached Files:

  9. sevoneone macrumors 6502

    Joined:
    May 16, 2010
    #9
    Most routers block NAT Loopback, meaning they won't let the same packets going out come back via the same port as it opens all kinds of possible security vulnerabilities. By trying to connect to your external IP address you are doing just that. Some routers have the ability to turn this off, but most consumer cable/dsl modems are going to have it baked into them by your ISP anyway.

    To test this properly, your windows machine needs to be outside your network. You can give it a shot while you are at work or head down to Starbucks, buy a coffee and test it out from there.

    If you want to test that your Windows PC can connect to your Mac while inside your network, just connect to your Mac's local IP address to to make sure everything is working there first.
     
  10. JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #10
    Problem solved...

    The issue is my Windows PC which is work PC and they have a group policy that prevents VNC connections to an public IP address which explains i) why it did work with the local IP address and ii) why it did NOT work with the public IP address...

    This means, I off to look for another solution...

    With much thanks...
     

Share This Page