(Beta 2) Music App Will Not Load Library

rwilliams

macrumors 68040
Original poster
Apr 8, 2009
3,593
685
Raleigh, NC
I'm hoping someone can help with this, because I've yet to find an answer here or on Reddit.

This actually began with Beta 1 and has continued through Beta 2. When I open the Music app, it will not load my old iTunes library of music. "Loading iCloud Music Library" just spins indefinitely and "Waiting to Upload Songs" appears indefinitely in the status bar. I have the new Music Library.musiclibrary file in /Users/myusername/Music/Music and I've tried adding my folders of songs in both that directory and in /Users/myusername/Music/Music/Media. Still nothing.

If I manually import my songs again from the File menu, the Music app will process all of them and then they will show up and I can play them just fine. BUT, I can't close the app. If I close it or reboot the machine, Music loses everything all over again.

There's gotta be something I'm not doing right or something I'm not understanding about this new Music Library file or the location of my music. Or, it's just buggy as hell and I've gotta wait for Apple to fix it in a future beta :)

Has anyone else encountered this, and if so, have you fixed it?
 
  • Like
Reactions: ABSoffer

ABSoffer

macrumors newbie
Jun 30, 2019
1
0
I'm hoping someone can help with this, because I've yet to find an answer here or on Reddit.

This actually began with Beta 1 and has continued through Beta 2. When I open the Music app, it will not load my old iTunes library of music. "Loading iCloud Music Library" just spins indefinitely and "Waiting to Upload Songs" appears indefinitely in the status bar. I have the new Music Library.musiclibrary file in /Users/myusername/Music/Music and I've tried adding my folders of songs in both that directory and in /Users/myusername/Music/Music/Media. Still nothing.

If I manually import my songs again from the File menu, the Music app will process all of them and then they will show up and I can play them just fine. BUT, I can't close the app. If I close it or reboot the machine, Music loses everything all over again.

There's gotta be something I'm not doing right or something I'm not understanding about this new Music Library file or the location of my music. Or, it's just buggy as hell and I've gotta wait for Apple to fix it in a future beta :)

Has anyone else encountered this, and if so, have you fixed it?

Same problem. About 80Gb of music

If Apple Music Loads it says "waiting to upload icloud library".