Beta 4 seems to fix the Pebble watch:)

Discussion in 'iOS 8' started by BrettDS, Jul 21, 2014.

  1. BrettDS macrumors 65816

    Joined:
    Nov 14, 2012
    Location:
    Orlando
    #1
    It might still be a bit too early to tell, but so far my Pebble has stayed connected to my phone and I've been getting notifications for more than 3 hours now. With the earlier betas the watch wouldn't stay connected for more than 45 minutes or an hour max and often only 5 or 10 minutes.

    For what it's worth, after I installed beta 4 I forgot the pebble bluetooth devices on my phone, deleted the pebble app and reset the watch to factory defaults. Then I reinstalled the app and reconnected everything. I'm not sure if that was necessary or not, but so far it's working much better than it had with the earlier betas.
     
  2. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #2
    Good to know as my steel turns up tomorrow!! My original one crapped out on notifications.
     
  3. grinny11 macrumors regular

    Joined:
    Aug 12, 2008
    #3
    My notifications stopped when I walked away from my phone and lost connection with my watch. When I got close it it, it said i was connected to both BT connections, but didn't get any notifications.

    I toggled bluetooth and notifications started working. Still better than previous betas...
     
  4. grockk macrumors 6502

    grockk

    Joined:
    Mar 16, 2006
    #4
    That happens to me occasionally on iOS 7.
     
  5. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #5
    Nope. Pebble still having same issues for me in beta 4 as in beta 1-3.
     
  6. mitchsaunders macrumors 6502

    Joined:
    Jun 7, 2014
    Location:
    Brisbane, Australia
    #6
    my kickstarter's still cracking up with ios 8 b4 for me too... Not happy
     
  7. BrettDS thread starter macrumors 65816

    Joined:
    Nov 14, 2012
    Location:
    Orlando
    #7
    For what it's worth, my pebble has still been connected and receiving updates without problems for more than 28 hours now.

    As I said above, after I installed iOS 8 beta 4 I did the following:

    On the phone, go to bluetooth and hit the (!) by each of the pebble bluetooth devices and then click on "Forget this device"

    On the watch, go to settings, then factory reset

    On the phone turn bluetooth off then on again (or just reboot the phone)

    On the phone, delete the pebble app, then download the pebble app again

    Start the pebble app and enter your pebble account info

    I wasn't able to pair my watch through the app... it never showed any devices, so when you get to that step in the app just cancel out of pairing and go back to bluetooth on the phone and pair that way. Then when you re-enter the app it will find the watch and you can continue the setup process.

    If you're still having trouble with your pebble and beta 4, try the above and see if that helps.
     
  8. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #8

    Well I started with a pebble steel that arrived today, so pretty much covered most your suggestion and it don't work.
     
  9. BrettDS thread starter macrumors 65816

    Joined:
    Nov 14, 2012
    Location:
    Orlando
    #9
    Hmm, that's really odd. I wonder what the difference is. What are the problems that you're seeing? With the earlier betas I would be able to get the watch connected, but the LE connection would drop and/or I'd simply stop receiving notifications within a few minutes. Occasionally it would last as long as 45 minutes or an hour, but I don't think it ever went longer than that before beta 4.
     
  10. mitchsaunders macrumors 6502

    Joined:
    Jun 7, 2014
    Location:
    Brisbane, Australia
    #10
    Mine lasts around a couple of hours, from 7am - it's once around 10 pm I've constantly noticed a dropoff of notifications - and most of the time started happening while I was on 3G - a bit odd (at 10 pm I'm on 3G, WiFi shuts off).
     
  11. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #11

    My kickstarter worked when I updated from iOS 7 to the iOS 8 beta. I had some issues so did a clean install in beta 2, had problems with pebble then. Think updating kept it working but setting up as new is just not having it.

    It seems to not be picking up the BTLE on either of my pebbles. Only the main BT connections. That's probably why.
     
  12. MyRomeo macrumors 6502

    MyRomeo

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #12
    Mine seems to work also.

    I had to forget the phone via the watch and then both pebble and pebble LE on the phone and re-pair. It took a few attempts but is working smooth now.

    I have noticed that if I lose bluetooth connection the app will drop notifications but simply forcing the app closed and reopening it fixes it.
     
  13. Optimus Rhyme macrumors regular

    Joined:
    Oct 28, 2006
    Location:
    London, UK
    #13
    I tried this all myself and got everything working again. Beta 3 I had notifications working but it would lose the pairing from time to time. Beta 4 I lost notifications, but after doing all of this, I now have them back. I'll report back if everything stops working at some point.
     
  14. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #14
    Oddly its sprung to life! Getting the notifications through fine now. Random!!
     
  15. grinny11 macrumors regular

    Joined:
    Aug 12, 2008
    #15

    Noticed force killing the app makes notifications work again too. Now I'll be obsessively closing and opening the app.
     
  16. MyRomeo macrumors 6502

    MyRomeo

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #16
    Grinny11, I've only had to force quit the app once or twice, no need to get obsessive :)
     
  17. geekonthepc macrumors member

    geekonthepc

    Joined:
    Nov 5, 2013
    #17
    I've had relative success with beta 4 and my Pebble - certainly the best it's been in any of the betas so far.

    Mine pairs fine now but up until yesterday I was getting "Notifications not setup" even though I seemed to be getting most notifications absolutely fine. However, last night it reconnected after the battery on my pebble went flat and since then the app has been absolutely fine.

    Still think there are a few optimisations to make for iOS 8 just to fine tune it (as people say, the app will not pair the Pebble - you have to do it manually + telling the Pebble app to setup notifications always seems to fail), but I think Apple have done most of the work in terms of improving the Bluetooth handler. Pebble just need to update their app ready for iOS 8 now.
     

Share This Page