willdude

macrumors regular
Original poster
Jul 16, 2010
198
145
I plugged my iPhone 7 into my Windows 10 PC at home and was surprised to see that my phone, which usually has mobile hotspot turned *off*, showed 1 hotspot connection. After a little digging, I found that by plugging it into my PC, hotspot had been automatically enabled, and the PC was using it as a tether. What's more, my PC was preferring it over its *regular* internet connection, and I'd accidentally downloaded a couple albums to my PC using mobile hotspot and used up 700MB of cellular data in a few minutes.

This didn't used to happen, so I suspect something changed on the PC side, either an iTunes updates or something with a recent Windows update (maybe the Spring feature update). The solution was to go to my network connections in control panel and disable the iPhone connection. Disabling it seemed to persist across disconnecting/reconnecting the phone.

So if you're like me, still old-fashioned, and preferring to sync/backup your iPhone over iTunes, keep an eye out for this so you don't accidentally use up all your data with an unintentional mobile tether.
 

Jimmy James

macrumors 603
Oct 26, 2008
5,468
4,050
Magicland
This is beyond absurd. There's absolutely no logical reason for this that is favorable to the user. So what's the other motivation for implementing this?
 
  • Like
Reactions: Regime2008
Comment

Regime2008

Suspended
Oct 3, 2017
720
798
Basshead in ATL
I'm guessing this is an apple thing, as my phone doesn't automatically enable tethering when plugging it into my computer. Running the latest build of Windows 10.
 
Comment

Raist3001

macrumors 65816
Mar 5, 2012
1,109
864
Right behind you
On second thought, it's possible that Mobile hotspot on Windows 10 is set to remotely connect if the phone is paired via bluetooth. So check your Windows 10 mobile hotspot settings.
 
  • Like
Reactions: daflake
Comment

bopajuice

Suspended
Mar 22, 2016
1,571
4,348
Dark side of the moon
It happens to me when I plug my iPhone directly into my MacBook Air. I don't plug in my phone to my laptop very often, but it has been doing this for a while. At least the last few iOS updates. Since it appears to happen even if you plug it into a Windows 10 machine, it must be an iOS issue. Even if I have hotspot turned off on my phone, my MB Air and iPad can still connect to the hotspot connection. Several times I have taken my iPad out of my backpack to find it is already connected to the hotspot connection on my phone.

If I am at home on my home network everything works as it should. But when I am on the road and take along my MB Air and iPad, hotspot connects to those devices whether hotspot is turn on or off.
 
Comment

Wyckham

macrumors regular
Dec 5, 2017
116
55
**** Microsoft - I always was and still am a Windows user on my gaming PC. The recent update to resume windows where you left off with chrome tabs and all reopen without the option to disable this feature has me hating microsoft. A horrible feature, wouldnt be so bad if there was an option to disable.
 
Comment

daflake

macrumors 6502a
Apr 8, 2008
920
4,326
**** Microsoft - I always was and still am a Windows user on my gaming PC. The recent update to resume windows where you left off with chrome tabs and all reopen without the option to disable this feature has me hating microsoft. A horrible feature, wouldnt be so bad if there was an option to disable.


Uh, okay... A little (or a lot) off topic.


I wonder if this is some undocumented feature. What happens if you connect the phone and allow hotspot to start. Disable it while connected and then disconnect. Try plugging back in to see if that resolves it? Just a thought...
 
Comment

Wyckham

macrumors regular
Dec 5, 2017
116
55
Its not off topic if Microsfot recently enabled it with an update.... I was happy with my OS before the stupid update which caused another issue. I find it interesting others might have different issues with Microsofts new BS
 
Comment

Regime2008

Suspended
Oct 3, 2017
720
798
Basshead in ATL
**** Microsoft - I always was and still am a Windows user on my gaming PC. The recent update to resume windows where you left off with chrome tabs and all reopen without the option to disable this feature has me hating microsoft. A horrible feature, wouldnt be so bad if there was an option to disable.
If it is chrome, you can disable this by right clicking chrome on the bottom right taskbar, and disable that feature. I turn it off myself, as I usually have over 50 or so tabs open at a time.
[doublepost=1526994848][/doublepost]
Its not off topic if Microsfot recently enabled it with an update.... I was happy with my OS before the stupid update which caused another issue. I find it interesting others might have different issues with Microsofts new BS
Others have stated its an Apple issue....
 
  • Like
Reactions: daflake
Comment

daflake

macrumors 6502a
Apr 8, 2008
920
4,326
Its not off topic if Microsfot recently enabled it with an update.... I was happy with my OS before the stupid update which caused another issue. I find it interesting others might have different issues with Microsofts new BS

Just had my phone plugged in this morning and it didn't do it so no, it isn't an issue.
 
  • Like
Reactions: Regime2008
Comment

Wyckham

macrumors regular
Dec 5, 2017
116
55
If it is chrome, you can disable this by right clicking chrome on the bottom right taskbar, and disable that feature. I turn it off myself, as I usually have over 50 or so tabs open at a time.

That is and always was disabled. Thanks it is a good suggestion.

Ive just looked into this again and apparently in the update from a few days ago they added the option to disable this annoying feature:

https://superuser.com/questions/122...ce=google_rich_qa&utm_campaign=google_rich_qa
 
Comment

daflake

macrumors 6502a
Apr 8, 2008
920
4,326
Comment

willdude

macrumors regular
Original poster
Jul 16, 2010
198
145
On second thought, it's possible that Mobile hotspot on Windows 10 is set to remotely connect if the phone is paired via bluetooth. So check your Windows 10 mobile hotspot settings.

My PC doesn't even have bluetooth, and I've never used any sort of hotspot with it. It's possible this isn't as recent occurrence as I think, and I'd just never noticed it before, but I've definitely never done anything to explicitly enable hotspot usage between my phone and PC. (And as I mentioned, hotspot is *disabled* on my phone when this occurs, but the PC causes it to automatically become enabled.)
 
Comment

Raist3001

macrumors 65816
Mar 5, 2012
1,109
864
Right behind you
My PC doesn't even have bluetooth, and I've never used any sort of hotspot with it. It's possible this isn't as recent occurrence as I think, and I'd just never noticed it before, but I've definitely never done anything to explicitly enable hotspot usage between my phone and PC. (And as I mentioned, hotspot is *disabled* on my phone when this occurs, but the PC causes it to automatically become enabled.)

Check your Ethernet adapters, do you see a Virtual Wi-Fi adapter?
 
Comment

ActionableMango

macrumors G3
Sep 21, 2010
9,606
6,867
This is beyond absurd. There's absolutely no logical reason for this that is favorable to the user. So what's the other motivation for implementing this?

Well mine doesn't do this. I have fully updated W10, fully updated iOS, and tethering enabled.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.