BF2142 help

Discussion in 'Mac and PC Games' started by *jachob*, Jul 10, 2010.

  1. *jachob* macrumors newbie

    Joined:
    Jul 10, 2010
    #1
    i got the game a few years back and i cant seem to play online... it tells me to download some patches but when i do so at about halfway in the installation it says some of the files have been modified and will automatically quit the installation. can anyone help me out here it also says i need to re-install the game but i've already done that 4-5 times and its a pain in the a** to do it over and over again.

    Thnx
     
  2. OpenLaszlo macrumors member

    OpenLaszlo

    Joined:
    Jan 3, 2009
    #2
    I'm unaware of a mac version of this game being released, so I'm assuming you are playing it through boot camp (which I have done successfully). Where exactly are you downloading the patches from? And which ones are you trying to install?
     
  3. *jachob* thread starter macrumors newbie

    Joined:
    Jul 10, 2010
    #3
    i have tried using many sources such as the official BF website but they all say the same thing halfway in the patch update
     
  4. SandboxGeneral Moderator emeritus

    SandboxGeneral

    Joined:
    Sep 8, 2010
    Location:
    Detroit
    #4
    I'm having the same problem. I wanted to get back to playing some BF2142 on my Mac (the Mac version) and reinstalled it on my MBP and my iMac. I downloaded the 1.5 patch and applied it to the MBP first and it went smoothly. I then tried to apply the patch on my iMac and it causes nothing but trouble. It won't take and either says it cannot install or that files have been modified and I need to reinstall.

    I've installed and uninstalled the game many times and tried to patch but get the same results. Usually at about 60 percent it locks up the entire iMac and I have to press the power button to restart it as everything gets locked up.

    I've repaired permissions and that didn't help. I started doing this the other day with 10.6.4 and again today after 10.6.5 but there is no difference.

    Has anyone else had this issue and overcome it?
     

Share This Page