Big problem with blur in old PC games. (how to enable nearest neighbour filtering?)

Discussion in 'Windows, Linux & Others on the Mac' started by TetheredHeart, May 22, 2015.

  1. TetheredHeart macrumors newbie

    Joined:
    Oct 24, 2012
    #1
    Hi. I have Windows 7 installed through Boot Camp on a Macbook Pro with Intel Iris graphics.

    I was happy to install Windows 7 and play some old classics, but have a big problem. The games look like a blurry mess and are completely unplayable. When I select no enhancements in games and get a nice 1:1 mapped tiny windowed picture, when I full screen the graphics or enlarge the window I get an extremely blurry picture. I simply cannot play like that. I love pixel graphics and looking at the screen like that just makes me cry. I want to see those big, sharp pixels.

    Even if the launcher allows me to render the game at a double or triple resolution with nearest neighbor mapping, I get a result which, although pixelish, is still somewhat blurry. I couldn't find anything in the Intel graphics settings to help me, also disabled ClearType. I want system wide nearest neighbour mapping of low resolution programs to the display resolution, is that too much to ask? :(

    I'm devastated. I don't know what to do. This renders my Windows 7 installation completely unusable, since I want to develop and play pixel art games. Can anyone help me?

    Thank you, any and all ideas are welcome.
     
  2. TetheredHeart thread starter macrumors newbie

    Joined:
    Oct 24, 2012
    #2
    I made a step forward, at least with the development tool I will use. In GameMaker Studio I disabled "interpolate colors between pixels" in Global Game Settings. Now at least the games I make won't look like crap on people's computers and I can see the actual result while testing. :)

    Kinda important I did that first. Still have problems with running old games though. Need all the help I can get, and I'm sure some people who stumble onto this could use it too.
     
  3. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #3
    Windows 7 sucks on retina displays, because it doesn't have HiDPI support.

    You'll need Windows 8 and set the scaling to 150% or 200%.
     

Share This Page