Big problem with my G5

am1971

macrumors member
Original poster
May 18, 2005
62
0
Barcelona...
Hi,

I've got a serious problem with my G5 Dual 2g running 10.4.1

Yesterday I was just using internet when this screen came down telling me I had to shut the computer down using the power button on the front.

I did that, because I couldn't click anything while this screen was there, and when it did I got something like a terminal window. I can't remember too much about what it said but one of the options was to type 'mac-boot' to start.

I typed that and it started up ok and was fine until today. I got the screen telling me to shut down again and now when I try to start up the computer nothing happens. It powers on but nothing shows up on the monitor.

The little blue light on the front flashes 3 times, stops, flashes 3 times, stops etc constantly. Also the fan starts and gets louder and louder and louder as time goes on.

I've turned it off totally, unplugged everything and left it alone for a while but when I try again the same thing happens. I don't think I can even start up from a CD.

If anyone has any idea what's going on or how to fix it I'd really appreciate any info/suggestions.

Thanks, am1971 :confused:
 

Church

macrumors regular
May 9, 2005
155
0
Alabama
That's kinda weird. I saw kinda the same thing last night. I walked past my dad's imac g3 400mhz, and it had this black screen with the power symbol behind the words saying "restart your computer with this button or this way" blah blah blah. Oh, and it said it in 3 other languages too. So, I thought i'd do my dad a favor and restart it. I guess it turned out ok because he didn't come in asking me what was going on, and when I saw him, he looked to be doing what he always does on it... It might have just been something he was doing before i walked past it though, so this post may totally be unrelated....
 

ITASOR

macrumors 601
Mar 20, 2005
4,400
3
Church, that sounds like a Kernel Panic. Search on these forums or google it.
 

crees!

macrumors 68000
Jun 14, 2003
1,921
26
MD/VA/DC
Yep, that's a kernel panic. Sort of like M$ blue screen of death. You should pop in your OS CD and hold down either Option, or C. I can't remember which. Boot from the CD and run Disk Utility. Hopefully that'll clear things up for you.
 

iriejedi

macrumors 6502a
Oct 4, 2000
807
116
Nor Cal
DIsk Repair

crees! said:
Yep, that's a kernel panic. Sort of like M$ blue screen of death. You should pop in your OS CD and hold down either Option, or C. I can't remember which. Boot from the CD and run Disk Utility. Hopefully that'll clear things up for you.

WHile I have not seen it so extreme - I had one where it would boot to the KP screen or to the part where the dock pops up and got stuck there popping up the dock over and over and over again....

\Disk Repair - repairing disk permissions solved it all.

Good luck - I hope this helps a little. A fresh install of 10.4 I also recommend - do the full install and archive vs an upgrade install. I've had no problems at all since I did that.
 

am1971

macrumors member
Original poster
May 18, 2005
62
0
Barcelona...
I can't open the drive to boot from the CD. When I start it up there's an initial 'whirr' as per normal but after that nothing. The monitor stays dark.

I took out the extra ram I had installed months ago in case it was something to do with that but it was the same. Would it be worth doing the same with the ram that came pre-installed?
 

Biker21098

macrumors member
Aug 13, 2002
74
0
CA
motherboard

I hate to say it, but it sounds like a busted motherboard. I only say this because my buddy with a dual 2.5 just had the same problem. Finally after 2 weeks we got it to boot off a laptop in target disk mode, but the fans were on high all the time. We got his info off and sent it to the repair shop. The repair shop got a replacement motherboard, and same thing happened, on the second new motherboard from apple it all worked again. Then my other friend with a dual 2 like yourself just the same issue. No booting, not even from CD/DVD. sent it in needed a new motherboard, on the second replacement it all worked. Kinda wild, seems apple, or their supplier is having issues with their motherboards. Makes me concerned about my soon to be 2.7 or maybe Hopefully dual 3.0GHz purchase. Its bout time, I've had my sawtooth forever. So send it in, hopefully still under warranty. Good luck, keep us posted, but I might think its the motherboard.
 

alexprice

macrumors 6502a
Jan 8, 2005
628
0
am1971 said:
Hi,

I've got a serious problem with my G5 Dual 2g running 10.4.1

Yesterday I was just using internet when this screen came down telling me I had to shut the computer down using the power button on the front.

I did that, because I couldn't click anything while this screen was there, and when it did I got something like a terminal window. I can't remember too much about what it said but one of the options was to type 'mac-boot' to start.

I typed that and it started up ok and was fine until today. I got the screen telling me to shut down again and now when I try to start up the computer nothing happens. It powers on but nothing shows up on the monitor.

The little blue light on the front flashes 3 times, stops, flashes 3 times, stops etc constantly. Also the fan starts and gets louder and louder and louder as time goes on.

I've turned it off totally, unplugged everything and left it alone for a while but when I try again the same thing happens. I don't think I can even start up from a CD.

If anyone has any idea what's going on or how to fix it I'd really appreciate any info/suggestions.

Thanks, am1971 :confused:
That sounds like a RAM problem.

Alex
 

aussie_geek

macrumors 65816
Apr 19, 2004
1,093
0
Sydney Australia
am1971 said:
I can't open the drive to boot from the CD. When I start it up there's an initial 'whirr' as per normal but after that nothing. The monitor stays dark.

I took out the extra ram I had installed months ago in case it was something to do with that but it was the same. Would it be worth doing the same with the ram that came pre-installed?
Make sure your Mac is off to do this:

What you can do is open the flap on the drive door so you can see the drive tray. There is a little hole that is on the bottom - just under the tray. This hole is the manual release for the tray. Straighten out a paper clip and insert it into to the hole and push it in until the cd tray opens.

When it is open, gently pull the tray out and then insert your disk (the hardware test CD or the OS install disk). Push the tray shut again and then restart your Mac with the 'C' key depressed. Good Luck


aussie_geek
 

am1971

macrumors member
Original poster
May 18, 2005
62
0
Barcelona...
alexprice said:
That sounds like a RAM problem.

Alex
I've tried with Apple's ram only, the problem exists. I've tried without the Apple ram and it exists. I have also removed the battery and done the pmu reset thing. No joy.

I think the motherboard problem as described above seems most likely.
 

mojohanna

macrumors 6502a
Jul 7, 2004
871
0
Cleveland
STOP!!! Don't waste your time doing any of the above. I had the EXACT same problem with my dual 1.8. I mean to the "t" exact. It is in fact a bad logic board as Apple calls them. Take it back or send it back (presuming it is under warranty) and have them take care of it. It is not worth your time and hassle factor to run all of these tests, take out and replace ram etc. If by some unfortunate stroke of timing your machine is out of warranty, expect to pay $700-800 (that was the cost of the board, no labor install etc). I am assuming you are still under warranty....

Good, luck. My machine works like a charm.
 

Sun Baked

macrumors G5
May 19, 2002
14,874
57
Check the RAM...
RAM and Processor Verification: Power-On Self Test
A power-on self test in the computer’s ROM automatically runs whenever the computer is started up after being fully shut down (the test does not run if the computer is only restarted). If the test detects a problem, the status LED located above the power button on the front of the computer will flash in the following ways:
• 2 Flashes: No RAM is installed or detected.
• 3 Flashes: Incompatible RAM types are installed.
• 4 Flashes: No RAM banks passed memory testing.
• 5 Flashes: No good boot images are detected in the boot ROM (and/or there is a bad sys config block).
• 6 Flashes: The processor is not usable.
Although it still doesn't rule out a memory controller problem.

Although you could always try it with no memory to see if you switch to a double led flash.
 

Maxiseller

macrumors 6502a
Jan 11, 2005
846
0
Little grey, chilly island.
Ok well contrary to other people's opion on bad logic boards, I had the exact same problem too, and it WAS in fact a K panic which led to the corruption of a couple of core files I'm guessing.

A simple Archive and Install wiill do the trick. Pop in your install CD and hold down "c" on startup.
 

am1971

macrumors member
Original poster
May 18, 2005
62
0
Barcelona...
Having tried everything nothing worked. It's gone back to the shop. Will let you know what they say but it's definitely hardware and not a corruption of core files or anything like it.
 

tango472

macrumors newbie
Nov 27, 2004
16
0
i know how you feel!

i have had exactly the same problem.

my dual 1.8Ghz G5 kept freezing onscreen, so i reset the permissions and then reset the **** -f command (or similar).

on doing this the computer started up but the screen stayed black.
i've just had it checked out by a authorised apple techinician and he's told me that one of the processors is blown (cost approx. £400 quid for parts + labour)

i freaked out thinking i spent a fortune on buying the kit only 14months ago and did not buy the applecare cover!

in a state of shock at the moment, considering what to do!

anyone fancy a part ex. + cash for a G5 dual 1.8/2.0 or looking to seel your G5 let me know - 07958 001101 (nw london)
 

am1971

macrumors member
Original poster
May 18, 2005
62
0
Barcelona...
Just got it back. Turns out it was a RAM problem, one of the original 256mb cards was damaged and causing the problem. The strange thing is I took out the original RAM and still had the problem but they replaced it and now everything's working fine.

Thanks to all for your suggestions and tips.